php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47226 strtolower error
Submitted: 2009-01-27 21:16 UTC Modified: 2009-01-27 22:33 UTC
From: jair at uninove dot br Assigned:
Status: Not a bug Package: *Languages/Translation
PHP Version: 5.2.8 OS: Ubuntu 8.04
Private report: No CVE-ID: None
 [2009-01-27 21:16 UTC] jair at uninove dot br
Description:
------------
strtolower is not converting some characters even with the correct LANG settings

Reproduce code:
---------------
LANG=pt_BR
LC_ALL=pt_BR
LC_CTYPE=ISO-8859-1
export LANG LC_ALL LC_CTYPE

<?
$m="ABRA??O";
echo strtolower($m);
?>


Expected result:
----------------
abra??o

Actual result:
--------------
abra??o

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-27 21:27 UTC] bjori@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 [2009-01-27 22:33 UTC] jair at uninove dot br
Thanks, just for helping out anybody that come here in the future: on ubuntu you must generate the locale with "locale-gen locale".

locale-gen pt_BR worked for me!
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Fri Nov 16 12:01:26 2018 UTC