php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47196 improve render of initializer tag
Submitted: 2009-01-23 10:06 UTC Modified: 2009-02-12 18:11 UTC
From: pear at laurent-laville dot org Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID:
 [2009-01-23 10:06 UTC] pear at laurent-laville dot org
Description:
------------
This is not a bug, just a request to improve render (xhtml, pdf ...)

While I found, few days ago [1], that the PEAR Manual xhtml render shown two equal sign for initializer docbook tag, I've fixed the full PEAR repository to suppress this.

But I see that the equal sign was always too close to default parameter value.

For example 
$raw =TRUE

To improve the render to this one (notice the blank after =):
$raw = TRUE

I propose to patch the current version 0.4.3 of PhD,
xhtml.php,v 1.67.2.2.2.16 2009/01/07 18:06:27 bjori
with, in format_initializer() function

replace line 813:
            return '<span class="'.$name.'">=';
by:
            return '<span class="'.$name.'">= ';


PS: don't forget to see also the pdf renderer (even if I've not tested yet, I suppose we have the same problem)

Laurent

[1] http://news.php.net/php.pear.doc/11345


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-02-12 18:11 UTC] cweiske@php.net
This bug has been fixed in CVS. Since the websites are not directly
updated from the CVS server, the fix might need some time to spread
across the globe to all mirror sites, including PHP.net itself.

Thank you for the report, and for helping us make PHP.net better.

Will be in phd 0.4.4
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Wed Apr 23 18:01:55 2014 UTC