php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47169 cast, gettype
Submitted: 2009-01-20 14:57 UTC Modified: 2009-01-20 15:46 UTC
From: lunter at interia dot pl Assigned:
Status: Not a bug Package: Unicode Engine related
PHP Version: 6CVS-2009-01-20 (snap) OS: all
Private report: No CVE-ID: None
 [2009-01-20 14:57 UTC] lunter at interia dot pl
Description:
------------
total mishmash with casting and gettype

Reproduce code:
---------------
<?
 $v=(string)'';
 print('1. variable casted as string has type: '.gettype($v).'<br>');

 $v=(unicode)'';
 print('2. variable casted as unicode has type: '.gettype($v).'<br>');

 $v=(binary)'';
 print('3. variable casted as binary has type: '.gettype($v).'<br>');
?>

Expected result:
----------------
I suggest:

1. variable casted as string has type: string (OLD PHP 5 behaviour, in PHP 6 for binary operation)
2. variable casted as unicode has type: unicode

Actual result:
--------------
1. variable casted as string has type: unicode
2. variable casted as unicode has type: unicode
3. variable casted as binary has type: string

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-20 15:04 UTC] felipe@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 [2009-01-20 15:46 UTC] lunter at interia dot pl
This not a bug, this if feature request.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Sep 17 17:03:36 2021 UTC