php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47135 [RU] CHM Help Rusian; Left side tree UTF-8 not support;
Submitted: 2009-01-17 12:20 UTC Modified: 2009-03-09 07:44 UTC
Votes:4
Avg. Score:4.5 ± 0.9
Reproduced:4 of 4 (100.0%)
Same Version:4 (100.0%)
Same OS:4 (100.0%)
From: L_Star at mail dot ru Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: windows XP
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: L_Star at mail dot ru
New email:
PHP Version: OS:

 

 [2009-01-17 12:20 UTC] L_Star at mail dot ru
Description:
------------
In the russian CHM file left side navigation tree not support UTF-8,
and i sow incorrect symbols. Using this help file not comfortable.
for search some topics or create Favorite link it is not readable list of topics. this tree of topics must be in win1251.

and this is not bogus.
I am download latest Microsoft HTML Help SDK.
And Tree of chapters (topics) not support UTF8 
it is support Only Local Languages charsets for each language.

I am  decompile this CHM file. 
In the workshop Set - Russan language
and re-save hhc and hhk file in win1251 charset. 
And compile it - The Problem was solved!


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-03-09 06:46 UTC] L_Star at mail dot ru
I was download Latest CHM help file from 8 march - it was improved.
Now Left navigation tree at russian language viewed right.

Many thanks. You can close that Bug.
 [2009-03-09 07:44 UTC] bjori@php.net
Thanks for the headsup
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat May 28 14:05:47 2022 UTC