php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #47086 zend_mm_heap corrupted when php script calls sql commands to create DB/tables
Submitted: 2009-01-13 11:34 UTC Modified: 2009-01-16 11:28 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: tshanmugapriya at alcatel-lucent dot com Assigned:
Status: Not a bug Package: Unknown/Other Function
PHP Version: 5.2.8 OS: HP-UX 11.11
Private report: No CVE-ID: None
 [2009-01-13 11:34 UTC] tshanmugapriya at alcatel-lucent dot com
Description:
------------
Installed apache(2.2.10) and php(5.2.8) on HP-UX 11.11 server. Trying to setup testlink tool that needs php 5.2. Im able to open index and other php pages. When installNewDB.php (which creates the database and tables) is called, Page can not be displayed message is shown in IE and "zend_mm_heap corrupted" is logged in apache's error_log.

Checked in google for the similar bugs reported. Got HP's binary file compiled with few of the options that were suggested but still no luck, hitting into same issue. 

Latest build in HP official site with -DZEND_MM_HEAP_PROTECTION option.
http://hpux.connect.org.uk/hppd/hpux/Languages/php-5.2.8/

Please provide fix for this issue.

Reproduce code:
---------------
installNewDB.php in testlink tool (install/index.php will lead to this page)

Tool can be downloaded from
http://www.teamst.org/ 

(this tool ois working well with xamp on Windows, with php5.1.1 version)

Expected result:
----------------
Above code should call the sql commands and run then on the server

Actual result:
--------------
zend_mm_heap corrupted
zend_mm_heap corrupted
zend_mm_heap corrupted

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-16 04:40 UTC] tshanmugapriya at alcatel-lucent dot com
Sorry, Im not good in php. I am trying to install the took testlink and the php script fails when it calls sql scripts to create the data base. This tool requires apache and mysql also.
 [2009-01-16 11:28 UTC] jani@php.net
Please ask someone who knows what they do to report. This report is just spam now.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jun 30 20:03:34 2022 UTC