php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #47032 contradictions in isset docs
Submitted: 2009-01-07 23:55 UTC Modified: 2009-05-08 19:06 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: charles at chaoslizard dot org Assigned:
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2009-01-07 23:55 UTC] charles at chaoslizard dot org
Description:
------------
The docs for isset (http://php.net/isset) are misleading and contradictory.

"Determine whether a variable is set"--that part would make sense alone.

Skip a sentence and it says "isset() will return FALSE if testing a variable that has been set to NULL".  If this sentence is true, the first sentence is false, misleading, and incomplete: it should read something like "Determine whether a variable is set to anything except NULL".

To put it another way, the problem is that it first claims to unconditionally check for a variable that "is set", but then claims to return FALSE for a variable that "has been set" to a particular value.

The problem could hinge on the nebulous definition of "set".  If this is the case, I'd suggest not using the phrase "has been set" in the later sentence.

It looks like bug #19080 may have prompted the documentation to read like it does now.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-08 19:06 UTC] danbrown@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 08:03:12 2021 UTC