php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46980 Rounding Error
Submitted: 2008-12-31 01:57 UTC Modified: 2009-01-05 11:54 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: gimmicklessgpt at gmail dot com Assigned: cseiler (profile)
Status: Not a bug Package: Math related
PHP Version: 5.2.6 OS: Linux
Private report: No CVE-ID: None
 [2008-12-31 01:57 UTC] gimmicklessgpt at gmail dot com
Description:
------------
When rounding, it will round incorrectly on one certain instance for sure. when rounding 0.145 with a precision of 2 it comes up with 0.14

Reproduce code:
---------------
echo round(0.145,2);

Expected result:
----------------
0.15

Actual result:
--------------
0.14

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-31 02:00 UTC] gimmicklessgpt at gmail dot com
additional note: 

while 0.145 rounds to 0.14 (incorrect)
0.155 rounds to 0.16 (correct)
 [2009-01-01 02:04 UTC] kalle@php.net
Christian, you were working with some rounding issues in 5.3, could you clarrify this?
 [2009-01-01 02:59 UTC] cseiler@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.


I cannot reproduce this issue with PHP 5.2.8. Could you check again if the version used was actually PHP 5.2.8? If so, could you please give some more details on the operating system and/or environment that was used? (i.e. also the processor architecture etc.)

That said: PHP's rounding behaviour improved somewhat in 5.2.7 and significantly in 5.3.0 alpha 3. I'm quite certain the problem you describe is fixed in 5.3.0 alpha 3 - but the case you are describing should not occur in 5.2.8 either, so I'd appreciate further details on your OS and platform.
 [2009-01-04 17:05 UTC] gimmicklessgpt at gmail dot com
Upon further me paying attention, my system definately says 5.2.6

I sincerely apologize for wasting your time
 [2009-01-05 11:54 UTC] jani@php.net
Per request. :)
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 08:04:05 2022 UTC