php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46971 Missing extensions between VC6 and VC9 snapshots
Submitted: 2008-12-30 12:05 UTC Modified: 2010-11-24 12:20 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: RQuadling at GMail dot com Assigned: pajoye (profile)
Status: Closed Package: Compile Failure
PHP Version: * OS: win32 only - Windows XP Pro SP3
Private report: No CVE-ID: None
 [2008-12-30 12:05 UTC] RQuadling at GMail dot com
Description:
------------
Hi.

I was playing with the 5.3.0alpha4-dev VC9 snapshots and wanted to 
take a look at the fileinfo extension.

I noticed that the following extensions are NOT present in the VC9 TS 
build:

php_fileinfo
php_mssql
php_pdo_mssql
php_sybase_ct

These are present in the 5.3.0alpha4-dev VC6 TS build.


If I use VC6 TS build, the extension works fine.

Reproduce code:
---------------
php -n -d extension_dir=.\ext -d extension=php_fileinfo.dll -r "$finfo = finfo_open(FILEINFO_NONE); echo getcwd(), PHP_EOL, finfo_file($finfo, './php.exe');"

Expected result:
----------------
D:\Personal Files\Downloads\Software\Programming\PHP\Latest 
Snapshots\php-5.3-win32-VC6-x86-latest
PE32 executable for MS Windows (console) Intel 80386 32-bit

and

D:\Personal Files\Downloads\Software\Programming\PHP\Latest 
Snapshots\php-5.3-win32-VC9-x86-latest
PE32 executable for MS Windows (console) Intel 80386 32-bit




Actual result:
--------------
D:\Personal Files\Downloads\Software\Programming\PHP\Latest 
Snapshots\php-5.3-win32-VC6-x86-latest
PE32 executable for MS Windows (console) Intel 80386 32-bit

and

PHP Warning:  PHP Startup: Unable to load dynamic library 
'.\ext\php_fileinfo.dll' - The specified module could not be found.
 in Unknown on line 0

Fatal error: Call to undefined function finfo_open() in Command line 
code on line 1





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-30 18:02 UTC] pajoye@php.net
fileinfo should be present in the next snapshots.

Sybase is not possible for now and will take some time until we have an updated SDK in place.

ntwdblib is not available anymore for VC9 and can't be used for mssql or pdo_mssql.
 [2009-05-25 12:18 UTC] pajoye@php.net
update:

gmp has been added using MPIR as backend.
mssql will not be present.
Firebird may be supported but the chance to be ready in time is very small.
 [2009-06-18 15:14 UTC] pajoye@php.net
Everything missing now won't be added in 5.3.0. Anything new will be added in 5.3.1 or HEAD only.
 [2010-06-20 19:10 UTC] pajoye@php.net
Update:

mssql and pdo_mssql won't be added.

snmp support has been restored in 5.3.3RC1 (VC9 only). Firebird will be in 5.3.3RC2.
 [2010-07-27 00:01 UTC] brett dot pavioni at att dot net
php_ldap.dll is missing from the Windows PHP 5.3.3 VC6 x86 Thread Safe ZIP File, although they exist in the VC9 files.
http://windows.php.net/downloads/releases/php-5.3.3-Win32-VC6-x86.zip
 [2010-07-27 00:27 UTC] pajoye@php.net
That's unrelated to what is described here. Sadly something that did not make it through the QA (this bug is about unsupported extension in 5.3.x releases).

I will upload the missing DLL soonish, next release will have the fix.
 [2010-08-11 14:28 UTC] zsbe17fr at yahoo dot fr
They are other dlls absent from php-5.3.3-Win32-VC6-x86.zip :
php_gmp.dll
php_zip.dll
 [2010-08-11 16:58 UTC] pajoye@php.net
Please do check your phpinfo before adding more comments here.

About GMP, it won't make it with VC6, move to VC9 if you need it.
 [2010-11-24 12:20 UTC] pajoye@php.net
-Status: Assigned +Status: Closed
 [2010-11-24 12:20 UTC] pajoye@php.net
firebird (and interbase) are back in 5.3.4 VC9 builds. sybase_ct is present too (since 5.3.1). Snmp made it in 5.3.3

I think we are now complete.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 08:01:24 2019 UTC