php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46935 Installing IIS+ISAPI fails because PHP5ISAPI.DLL not yet present
Submitted: 2008-12-23 12:54 UTC Modified: 2009-01-05 20:51 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: paul at cohsoft dot com dot au Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.8 OS: Windows XP
Private report: No CVE-ID: None
 [2008-12-23 12:54 UTC] paul at cohsoft dot com dot au
Description:
------------
This is bug #45685 restarted.
If you install PHP onto Windows XP with IIS+ISAPI, the procedure configIIS4 in script PHPInstallerScripts52.vbs fails on line 182 because it is trying use the File System Object to generate a short path. The FSO GetFile method fails if the file does not exist. The php5isapi.dll does not yet exist because the script is being executed during installation.
The problem doesn't occur on Windows Server 03, Vista or Server 08 because the script doesn't generate a short name for those operating systems.
I don't know of a simple fix for the problem. The windows GetShortPathName API function doesn't rely on a file existing, but VBScript can't call API functions.
Maybe the script can be deferred until the rest of installation is done, so the php5isapi.dll file *does* exist?
Workaround: Choose "Do not setup a web server" during first install of PHP. Download the PHP zip and unzip to a temp folder. Copy php5isapi.dll from temp folder to wherever PHP.EXE is. Manually configure IIS to use the ISAPI DLL.
Actual message:
Product: PHP 5.2.6 -- Error 1720. There is a problem with this Windows
Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor.  Custom action configIIS4 script error -2146828235, Microsoft VBScript runtime error: File not found Line 182, Column 9


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-01-05 20:51 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 04:05:45 2022 UTC