php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46933 valid backslashes in the docs are removed
Submitted: 2008-12-23 08:40 UTC Modified: 2008-12-24 03:18 UTC
From: haohappy@php.net Assigned:
Status: Not a bug Package: Doc Build problem
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
 [2008-12-23 08:40 UTC] haohappy@php.net
Description:
------------
I compiled PHP docs using PhD and found some valid backslashes in the docs are removed. These errors can be typically found in the chapter 'Namespaces'. 

Here is the right example:
http://www.php.net/manual/en/language.namespaces.nested.php

and here is my result:
http://www.phpeye.com/phpmanual/language.namespaces.nested.html



Reproduce code:
---------------
The commands I used:
php configure.php --with-lang=zh --enable-chm
/home/www/php/bin/phd -d .manual.xml -L zh

The html files were generated in the directory 'phpdoc-zh/chm/res' .

Expected result:
----------------
For example, the right code is:
<?php
namespace MyProject\Sub\Level;
?>

Actual result:
--------------
but the actual result I got was:
<?php
namespace MyProjectSubLevel;
?>

The backslashes '\' were missing.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-23 09:07 UTC] philip@php.net
Namespaces were added in PHP 5.3, so you need to run PhD with 5.3 because highlight_string() is used for the syntax highlighting.

Maybe it's time we require 5.3, or at least yell at people if they don't have it (and warn them about a few more things).
 [2008-12-23 10:34 UTC] bjori@php.net
People really should be using 5.3 for multiple reasons.
We however cannot require it as there still isn't released :(
 [2008-12-24 03:18 UTC] haohappy@php.net
Thanks!

I ran PhD with PHP5.3 and it worked well as you said.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Jul 05 01:01:27 2020 UTC