php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46871 [RU] New php_manual_ru.chm: wrong encoding in sidebar
Submitted: 2008-12-15 19:04 UTC Modified: 2012-04-18 09:44 UTC
Votes:21
Avg. Score:3.9 ± 1.0
Reproduced:15 of 16 (93.8%)
Same Version:11 (73.3%)
Same OS:11 (73.3%)
From: erema at blew dot ru Assigned:
Status: Closed Package: Doc Build problem
PHP Version: Irrelevant OS: Windows
Private report: No CVE-ID: None
 [2008-12-15 19:04 UTC] erema at blew dot ru
Description:
------------
The "contents" sidebar of new php_manual_ru.chm (5 Dec 2008) is encoded in UTF-8, but shown in WINDOWS-1251, so contents, search and other sidebar tabs output russian letters as unreadable hieroglyphs.

Manual's content itself is correct, only "sidebar" looks ugly.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-16 13:18 UTC] erema at blew dot ru
Have tested the .chm in Win98 (ru) and WinXP SP2 (ru) with the same result.

Here is screenshot: http://img511.imageshack.us/img511/9466/phpmanualrulq7.jpg
 [2008-12-16 13:26 UTC] erema at blew dot ru
[changing bug category]
 [2009-01-01 10:26 UTC] erema at blew dot ru
php_manual_ru.chm (build of 26 Dec 2008) - same problem
 [2009-01-01 10:39 UTC] erema at blew dot ru
It seams that the contents of sidebar is always shown in system's default encoding (the russian one is windows-1251 on MS Windows). Not sure, maybe its just a simple typo in a template, maybe its a feature of MS CHM Viewer.

[changing bug category again]
 [2009-01-01 13:19 UTC] bjori@php.net
I'll look into it once I get access to the windows box again.
 [2009-01-10 16:44 UTC] kalle@php.net
I can confirm it under Windows Vista, however not translated elements work fine
 [2009-01-11 19:03 UTC] erema at blew dot ru
translated works fine too, just unreadable due to a problem with encodings (and "search" function of the chm finds nothing with russian queries)

new build (10 jan 2009) - no changes
 [2009-02-11 08:27 UTC] bobrosoft at yandex dot ru
Have a same problem in 6 Feb 2009 build
 [2009-02-12 10:24 UTC] hipot at ya dot ru
Have a same problem in 6 Feb 2009 build at Windows XP3 Rus
 [2009-02-15 18:59 UTC] neonik at ukr dot net
Have a same problem in php_manual_ru.chm (13 Feb 2009 build) at Windows XP2 Rus!
:(
 [2009-02-15 19:41 UTC] bjori@php.net
This is probably fixed now..
Please verify that the CHM (dated *after* this note) does not have this issue anymore.
 [2009-02-26 14:35 UTC] erema at blew dot ru
Yes, its fixed! Huray! Thanks!

Little bug still here: "index" tab shows windows-1251 letters in some other encoding, probably windows-1252.
Here's screenshot:
http://img211.imageshack.us/img211/7757/20090226173202.png
 [2009-05-26 12:50 UTC] tarasov dot igor at gmail dot com
Confirm here, on kchmviewer in kubuntu. Contents now okay, but words index is broken.
 [2010-05-16 23:27 UTC] kalle@php.net
Hannes, FYI: the russian chm aren't build automaticlly build anymore as it the translation wasn't updated anymore
 [2010-06-04 11:21 UTC] pajoye@php.net
-Status: Assigned +Status: Feedback
 [2010-06-04 11:21 UTC] pajoye@php.net
Please try again, a couple of fixes have been applied.
 [2012-04-17 18:48 UTC] bjori@php.net
-Status: Feedback +Status: No Feedback
 [2012-04-17 18:48 UTC] bjori@php.net
-Assigned To: bjori +Assigned To:
 [2012-04-18 09:44 UTC] erema at blew dot ru
"contents" is ok for now, but "index" tab is in wrong encoding ( screenshot: http://d.pr/i/RvVu ), and "search" doesn't search queries in russian
 [2012-04-18 09:44 UTC] erema at blew dot ru
-Status: No Feedback +Status: Closed
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Jan 23 10:03:35 2022 UTC