php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #46856 Make PHP use less CPU
Submitted: 2008-12-13 06:56 UTC Modified: 2008-12-14 13:35 UTC
Votes:7
Avg. Score:3.3 ± 2.0
Reproduced:3 of 4 (75.0%)
Same Version:2 (66.7%)
Same OS:2 (66.7%)
From: tim987 at email dot com Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 5.3.0alpha3 OS: Windows/Linux
Private report: No CVE-ID:
 [2008-12-13 06:56 UTC] tim987 at email dot com
Description:
------------
PHP should use the lowest CPU usage on a server so large websites that get millions of visitors per day will only need 1 dedicated server instead of a cluster of servers. For example, wikipedia uses PHP, but because of the millions of users that visit it every month it needs 10 or 20 servers. So PHP should be the first programming language to use the lowest CPU usage possible so websites like this only need 1 dedicated server.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-14 03:27 UTC] a dot brilliant dot man at programmingexperts dot com
I, for one, think that this is a fantastic idea.  A way to start 
might be by removing the built-in libraries.  This should also lower 
the memory demands as well, if I'm not mistaken.
 [2008-12-14 03:28 UTC] newb234 at aol dot com
What a great idea, why didn't I think of that?!
 [2008-12-14 04:31 UTC] a dot nother dot expert at expert dot sexchange dot com
I agree.  It is said that the computing power of the Apollo space mission was equivalent to today's programmable calculator.  So it only makes sense that tomorrow's wikipedia should run on tomorrow's programmable calculator.  

Ask yourself why there have been no PHP powered space flights?

If you do not act fast, Java will own the space industry.  I hear it already runs on 2 of the 3 main brands of programmable calculator.
 [2008-12-14 13:35 UTC] scottmac@php.net
Patches welcome rather than nonconstructive criticism
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Thu Apr 17 01:01:56 2014 UTC