php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #46847 phpinfo() is missing some settings.
Submitted: 2008-12-12 12:46 UTC Modified: 2008-12-12 13:23 UTC
From: RQuadling at GMail dot com Assigned: bjori
Status: Closed Package: Feature/Change Request
PHP Version: 5.2.8 OS: Windows XP Pro SP3
Private report: No CVE-ID:
 [2008-12-12 12:46 UTC] RQuadling at GMail dot com
Description:
------------
I've been going through my ini files and realized I've not updated 
many of the new settings (since around 5.2.1).

In doing do, I notice that a couple of the settings are not shown in 
phpinfo();

bcmath.scale
bcompiler.enabled
dba.default_handler
exif.decode_jis_intel
exif.decode_jis_motorola
exif.decode_unicode_intel
exif.decode_unicode_motorola
exif.encode_jis
exif.encode_unicode
gd.jpeg_ignore_warning
ldap.max_links
runkit.internal_override
runkit.superglobal
uploadprogress.file.contents_template
uploadprogress.file.filename_template
uploadprogress.get_contents

In the following extensions, the DISPLAY_INI_ENTRIES(); call is 
missing from PHP_MINFO_FUNCTION():

bcmath, bcompiler (PECL), dba, exif, gd, ldap, runkit (PECL), 
uploadprogress (PECL 0.3.0, is present in 0.9.1)





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-12 13:23 UTC] bjori@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Fixed in HEAD and 5_3
Fixed bcompiler and runkit too
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 23:01:58 2014 UTC