php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46822 Short Open Tags doesnt work well
Submitted: 2008-12-10 13:23 UTC Modified: 2008-12-10 15:18 UTC
From: sskaje at gmail dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.8 OS: Windows
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: sskaje at gmail dot com
New email:
PHP Version: OS:

 

 [2008-12-10 13:23 UTC] sskaje at gmail dot com
Description:
------------
I try to get some old code running on my apache+php 5.2.8 laptop, then i turn 'short_open_tag = On'

but, code with tags like 
[code]<? phpinfo(); [/code]
cant be parsed as it should be, while code like 
[code]<?='asdf'?>[/code]
works

Reproduce code:
---------------
[code]<? phpinfo(); [/code]


Expected result:
----------------
PHP info page

Actual result:
--------------
direct output : <? phpinfo();

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-10 15:18 UTC] Thomas dot Worm at gsp-software dot de
[code]<? phpinfo(); [/code]
You forgot the end tag ?>
 [2008-12-10 15:18 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Most likely the php.ini file you edited is NOT the one used by PHP. And this is not a bug.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Jul 07 02:05:43 2022 UTC