php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46816 Upgrading with installer messes up php.ini
Submitted: 2008-12-09 21:16 UTC Modified: 2009-05-19 18:40 UTC
From: labsylabsy at gmail dot com Assigned: jmertic (profile)
Status: Wont fix Package: Windows Installer
PHP Version: 5.2.8 OS: win32 only
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-12-09 21:16 UTC] labsylabsy at gmail dot com
Description:
------------
Windows installer is bogus with parsing php.ini when using installer to UPGRADE existing setup. Some settings are duplicated or duplicated to default values, so PHP fails to start after upgrading.


Reproduce code:
---------------
By my testing, I can reproduce the same behaviour on ANY Windows machine, which runs PHP as ISAPI module on IIS 6 and you use PHP installer to upgrade previous (5.2+) version to latest 5.2.8 version.

Expected result:
----------------
PHP.INI configuration should be preserved, extensions and session.save_path should not be changed, and none of above should be duplicated. 

Indeed, you could also NOT select extensions to install within installation wizard, which would get rid of duplicated extensions failure, but by my oppinion, installer *should* be smart enough to recognise existing [EXTENSIONS] section and to not duplicate them at the end of php.ini file.

Actual result:
--------------
At least these errors are present after you use PHP installer to UPGRADE existing 5.2+ version to 5.2.8:
- EXTENSIONS get duplicated if you select to install existing extensions. Duplications however do not fall into [EXTENSIONS] tab, but are rather added to the very end of php.ini by upgrade process, so you most probably won't notice them at first sight.
- SESSION PATH gets duplicated at the end of [EXTENSIONS] section and is set to default session.save_path="C:\WINDOWS\Temp", regardles which path you had defined in existing php.ini file.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2009-05-19 18:40 UTC] jmertic@php.net
The installer cannot guarantee to properly configure manual installs that are upgraded using the installer. We recommend installing fresh an migrating your existing setting into the new install.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Oct 25 19:01:23 2020 UTC