php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46805 libmysqli.dll is missing
Submitted: 2008-12-09 02:17 UTC Modified: 2008-12-09 09:48 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: manga at premits dot com Assigned: pajoye (profile)
Status: Not a bug Package: MySQLi related
PHP Version: 5.2.8 OS: win32 only
Private report: No CVE-ID: None
 [2008-12-09 02:17 UTC] manga at premits dot com
Description:
------------
libmysqli is still mission in the 5.2.6 and 5.2.8 version. mysql extensions can't be loaded.

Reproduce code:
---------------
mysql_connect is not recognized

Expected result:
----------------
I receive the error stating that I'm calling an undefine function mysql_connect. I'm running the windows 2003 R2 server with php 5.2.8 and mysql 5.1.30.

I made a right installation. PHP runs a part, MySQL run apart but together they are not working; the extensions I think can't be loaded. I copied the necessary dlls in all what you can imagine as folder where they could have to be; noway. And I noticed that the libmysqli.dll is quite missing in the binaries. I copied it the from an older version; very old version as it's still missing in the newest version but no chance. It will not work. My PHP is not working with my mySQL on a windows 2003 R2 IIS Server. ---> And I can't say I'm the one who is doing anything wrong.

Actual result:
--------------
I hope to get an solution as I'm not able to run my server since 4 days and my project is stucking.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-12-09 09:38 UTC] manga at premits dot com
Hi,
I really need help as my PHP 5.2.6 comes without the libmysqli.dll. And I can't bring it to run with the mySQL version I have installed. Something is definitely run here. Maybe someone can really try to simulate the combination I have on a windows 2003 R2 server and get me a result back.

I tried it 4 days and work the whole night on this yesterday, but in vain. Please help me as I would not like to go back to older versions.
 [2008-12-09 09:48 UTC] pajoye@php.net
libmysqli is not present anymore since many many versions. The extensions load fine using 5.2.8 and libmysql.dll.

See http://phpfi.com/386488

be sure to enable it in your php.ini and to restart your web server.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Tue May 24 00:03:50 2022 UTC