php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46682 touch() atime field returns different value
Submitted: 2008-11-26 10:22 UTC Modified: 2009-07-07 22:13 UTC
From: ant@php.net Assigned: pajoye
Status: Closed Package: Filesystem function related
PHP Version: 5.3CVS-2008-11-26 (snap) OS: win32 only
Private report: No CVE-ID:
 [2008-11-26 10:22 UTC] ant@php.net
Description:
------------
The following test was ported from 5.2.X and does not behave the same 
on 5.3. It appears the atime stat field after running touch() returns 
a different value.





Reproduce code:
---------------
See the test now checked into CVS:

ext/standard/tests/file/touch_basic-win32.phpt



Expected result:
----------------
017- atime=20470

Actual result:
--------------
017+ atime=10000





Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-26 18:03 UTC] ant@php.net
These tests are also now checked into 6.0.
 [2009-01-12 19:32 UTC] pajoye@php.net
I found the reason and I have a fix. However I'm not sure yet it does not break more than it should. See: http://news.php.net/php.qa/64596


 [2009-07-07 22:13 UTC] pajoye@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 02:02:27 2014 UTC