php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46580 Chunks suddenly no longer accessible
Submitted: 2008-11-15 18:53 UTC Modified: 2008-11-30 12:34 UTC
From: hannes dot magnusson at gmail dot com Assigned: cweiske (profile)
Status: Not a bug Package: Doc Build problem
PHP Version: Irrelevant OS: Linux
Private report: No CVE-ID: None
 [2008-11-15 18:53 UTC] hannes dot magnusson at gmail dot com
Description:
------------
For some reason few sections are now chunked away, in some cases its available from the page TOC and in some cases its completely gone.

See:
http://docs.php.net/manual/en/preface.php (wrong)
vs
http://no2.php.net/manual/en/preface.php (correct)
The entire "Authors and Contributors" is gone and nowhere to be found.

See also:
http://docs.php.net/language.exceptions
vs
http://no2.php.net/language.exceptions
Now there suddenly is a new page for "Extending exceptions".


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-15 18:54 UTC] bjori@php.net
Christian, could you look into it?
 [2008-11-15 21:40 UTC] cweiske@php.net
Could have to to with bug #46415
 [2008-11-15 21:43 UTC] cweiske@php.net
Side effect of this?

http://cvs.php.net/viewvc.cgi/phd/include/PhDReader.class.php?view=log

Restore the old dsssl behavior and don't put the first section of
a chapter/chunking element on the same page, as discussed on the mailing
list [1].
This also fixes bug #46415: Don't chunk first section on parent site when
it has children. [2]
 [2008-11-30 12:34 UTC] cweiske@php.net
I don't see a problem here. This was an intended change.

If you want to restore the old behavior that the first subsections of any element shall be on the parent page, then we have a problem because this was not so in PEAR. And the previous implementation caused serious problems with TOC and navigation in case the auto-unchunked section had subsections itself.

In peardoc, you can use phd:chunk="false" to restore the old behavior.
That property has not been implemented for phpdoc themes, because php theme does not share the peardoc's toc generation function.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 17:01:28 2020 UTC