php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46480 Cannot find Sybase 64 bit libraries
Submitted: 2008-11-04 13:42 UTC Modified: 2008-11-09 13:14 UTC
From: leif dot gustafsson at hp dot com Assigned:
Status: Not a bug Package: Sybase-ct (ctlib) related
PHP Version: 5.2.6 OS: Linux
Private report: No CVE-ID: None
 [2008-11-04 13:42 UTC] leif dot gustafsson at hp dot com
Description:
------------
We are using Sybase 15.0.2 64 bit and its library names end with 64. I have to manually change the configure file to handle those names.

It should be possible to --enable-sybase64 to handle this.

Otherwise thx for an excellent way to handle OCI.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-04 22:28 UTC] jani@php.net
Please try using this CVS snapshot:

  http://snaps.php.net/php5.2-latest.tar.gz
 
For Windows:

  http://windows.php.net/snapshots/


 [2008-11-07 08:57 UTC] leif dot gustafsson at hp dot com
The problem is that the libs for the Sybase 64 bit has different names and are not found by the configure-script and the Makefile.

libsybdb.se => libsybdb64.so for 64 bit Sybase
libsybunic.se => libsybunic64.so for 64 bit Sybase

I had to manually change the configure script to handle this.

The newest php snapsdhot DO NOTT handle this.

-rwxr-xr-x  1 www uabwww  124320 2006-12-14 05:11 libsybblk64.so
-rwxr-xr-x  1 www uabwww  125132 2006-12-14 05:12 libsybblk_r64.so
-rwxr-xr-x  1 www uabwww  101305 2006-12-14 07:44 libsybblk_r.so
-rwxr-xr-x  1 www uabwww  101072 2006-12-14 07:42 libsybblk.so
-rwxr-xr-x  1 www uabwww  818634 2006-12-14 05:11 libsybcomn64.so
-rwxr-xr-x  1 www uabwww  841913 2006-12-14 05:12 libsybcomn_r64.so
-rwxr-xr-x  1 www uabwww  630302 2006-12-14 07:44 libsybcomn_r.so
-rwxr-xr-x  1 www uabwww  609698 2006-12-14 07:42 libsybcomn.so
-rwxr-xr-x  1 www uabwww   83364 2006-12-14 05:11 libsybcs64.so
-rwxr-xr-x  1 www uabwww   88249 2006-12-14 05:12 libsybcs_r64.so
-rwxr-xr-x  1 www uabwww   71081 2006-12-14 07:44 libsybcs_r.so
-rwxr-xr-x  1 www uabwww   67883 2006-12-14 07:42 libsybcs.so
-rwxr-xr-x  1 www uabwww  682773 2006-12-14 05:11 libsybct64.so
-rwxr-xr-x  1 www uabwww  683874 2006-12-14 05:12 libsybct_r64.so
-rwxr-xr-x  1 www uabwww  469712 2006-12-14 07:44 libsybct_r.so
-rwxr-xr-x  1 www uabwww  465445 2006-12-14 07:42 libsybct.so
-rwxr-xr-x  1 www uabwww 1291813 2006-12-14 05:11 libsybdb64.so
-rw-r--r--  1 www uabwww 1099181 2006-12-14 07:42 libsybdb.so
-rwxr-xr-x  1 www uabwww   56616 2006-12-14 05:12 libsybdldap64.so.15.0.3
-rwxr-xr-x  1 www uabwww   41023 2006-07-11 10:39 libsybdldap.so.15.0.1
-rwxr-xr-x  1 www uabwww   45256 2006-12-14 07:44 libsybdldap.so.15.0.3
-rwxr-xr-x  1 www uabwww  826321 2006-12-14 05:12 libsybfssl64.so.15.0.3
-rwxr-xr-x  1 www uabwww  640960 2006-12-14 07:44 libsybfssl.so.15.0.3
-rwxr-xr-x  1 www uabwww   41804 2006-12-14 05:11 libsybintl64.so
-rwxr-xr-x  1 www uabwww   41838 2006-12-14 05:12 libsybintl_r64.so
-rwxr-xr-x  1 www uabwww   33998 2006-12-14 07:44 libsybintl_r.so
-rwxr-xr-x  1 www uabwww   33996 2006-12-14 07:42 libsybintl.so
-rwxr-xr-x  1 www uabwww   23928 2006-07-11 08:29 libsybskrb64.so.15.0.1
-rwxr-xr-x  1 www uabwww   24464 2006-12-14 05:12 libsybskrb64.so.15.0.3
-rwxr-xr-x  1 www uabwww   19686 2006-07-11 10:39 libsybskrb.so.15.0.1
-rwxr-xr-x  1 www uabwww   20126 2006-12-14 07:44 libsybskrb.so.15.0.3
-rwxr-xr-x  1 www uabwww  179543 2006-12-14 05:11 libsybtcl64.so
-rwxr-xr-x  1 www uabwww  184200 2006-12-14 05:12 libsybtcl_r64.so
-rwxr-xr-x  1 www uabwww  143372 2006-12-14 07:44 libsybtcl_r.so
-rwxr-xr-x  1 www uabwww  138513 2006-12-14 07:42 libsybtcl.so
-rwxr-xr-x  1 www uabwww  962082 2006-12-14 05:11 libsybunic64.so
-rwxr-xr-x  1 www uabwww  652568 2006-12-14 07:42 libsybunic.so
 [2008-11-09 13:14 UTC] thekid@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Duplicate of Bug #45357 - as stated there: Please see if http://sitten-polizei.de/php/sybase-configm4.diff 
works for you.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 20 07:01:25 2020 UTC