php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46475 CCS event on button not working
Submitted: 2008-11-03 17:47 UTC Modified: 2008-11-03 22:04 UTC
From: mark dot lynch at crowley dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.6 OS: win2003
Private report: No CVE-ID: None
 [2008-11-03 17:47 UTC] mark dot lynch at crowley dot com
Description:
------------
I have recently upgraded my OS from windows 2000 to windows 2003. In the process we upgrade our php from 5.1.4 to 5.2.6 as 5.1.4 did not work with 2003. We have found that our only page which uses standard html button does not bind to its event handler on the server.

$Login->DoLogin->CCSEvents["OnClick"] = "Login_DoLogin_OnClick";

The function "Login_DoLogin_OnClick" never gets called.

Is there a feature I need to install to get this working. All the other CCS event binding seem to be work, Load, unload type etc.

Mark.

Reproduce code:
---------------
<?php
function BindEvents()
{
    global $Login;
    $Login->DoLogin->CCSEvents["OnClick"] = "Login_DoLogin_OnClick";
}

function Login_DoLogin_OnClick() { 
 echo("<p>Here2<p>");
 die();
}
?>
<html><head></head><body>
<form method="post" action="{Action}" name="Login">
    <input name="DoLogin" type="submit" value="Login" ><!-- END Button DoLogin -->&nbsp;</td>
</form></body></html>
<?php
BindEvents();
?>

Expected result:
----------------
The Page should show the message "Here2"

Actual result:
--------------
Page just refreshes and displays the button.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-03 22:04 UTC] johannes@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon May 20 01:01:32 2024 UTC