php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46426 3rd parameter offset of stream_get_contents not works for "0"
Submitted: 2008-10-30 08:15 UTC Modified: 2010-02-17 00:23 UTC
From: zhustar at gmail dot com Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 5.2.6 OS: Linux
Private report: No CVE-ID:
 [2008-10-30 08:15 UTC] zhustar at gmail dot com
Description:
------------
php 5.2.0
I want get the string from begin to the end ("12345")
but return empty when set offset to 0

Reproduce code:
---------------
<?PHP
$tmp = tmpfile();
fwrite($tmp, "12345");
//rewind($tmp);
echo "---\n";
echo stream_get_contents($tmp, -1, 0);
echo "\n";
echo stream_get_contents($tmp, -1, 1);
echo "\n";
echo stream_get_contents($tmp, -1, 2);
echo "\n---";
?>

Expected result:
----------------
---
12345
2345
345
---

Actual result:
--------------
---

2345
345
---

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-30 10:13 UTC] felipe@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

We need add a note in the documentation.
 [2010-02-17 00:23 UTC] joey@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php

Nothing to document here.
 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 18:01:58 2014 UTC