php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46342 IMAP support breaks libphp5.so
Submitted: 2008-10-20 09:13 UTC Modified: 2008-10-29 01:00 UTC
From: paul dot goorskis at ctco dot lv Assigned:
Status: No Feedback Package: IMAP related
PHP Version: 5.2.6 OS: OpenBSD 3.3
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-10-20 09:13 UTC] paul dot goorskis at ctco dot lv
Description:
------------
After adding '--with-imap' to configure build completes, but no 
libphp5.so generated.

Reproduce code:
---------------
# ./configure --prefix=/opt/php --with-apxs=/usr/sbin/apxs --enable-mbstring --with-libxml-dir=/opt/libxml2 --with-curl=/opt/curl --with-mysql=/opt/mysql --with-zlib=/opt/zlib --without-iconv --without-pear --disable-dom --without-sqlite --without-pdo-sqlite --with-kerberos=/opt/kerberos5 --with-imap-ssl=/opt/openssl --with-imap=/opt/imap

# make
...
Build complete.
...
# make install



Expected result:
----------------
# make install
Installing PHP SAPI module:       apache
[activating module `php5' in /var/www/conf/httpd.conf]
cp libs/libphp5.so /usr/lib/apache/modules/libphp5.so
chmod 755 /usr/lib/apache/modules/libphp5.so
cp /var/www/conf/httpd.conf /var/www/conf/httpd.conf.bak
cp /var/www/conf/httpd.conf.new /var/www/conf/httpd.conf
rm /var/www/conf/httpd.conf.new
Installing PHP CLI binary:        /opt/php/bin/
Installing PHP CLI man page:      /opt/php/man/man1/
Installing build environment:     /opt/php/lib/php/build/
Installing header files:          /opt/php/include/php/
Installing helper programs:       /opt/php/bin/
  program: phpize
  program: php-config
Installing man pages:             /opt/php/man/man1/
  page: phpize.1
  page: php-config.1
Installing PDO headers:          /opt/php/include/php/ext/pdo/














Actual result:
--------------
# make install
Installing PHP SAPI module:       apache
[activating module `php5' in /var/www/conf/httpd.conf]
cp libs/libphp5.so /usr/lib/apache/modules/libphp5.so
cp: libs/libphp5.so: No such file or directory
Installing PHP CLI binary:        /opt/php/bin/
Installing PHP CLI man page:      /opt/php/man/man1/
Installing build environment:     /opt/php/lib/php/build/
Installing header files:          /opt/php/include/php/
Installing helper programs:       /opt/php/bin/
  program: phpize
  program: php-config
Installing man pages:             /opt/php/man/man1/
  page: phpize.1
  page: php-config.1
Installing PDO headers:          /opt/php/include/php/ext/pdo/














Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-10-20 17:18 UTC] jani@php.net
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at
http://bugs.php.net/how-to-report.php

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.



 [2008-10-21 06:40 UTC] paul dot goorskis at ctco dot lv
Apache/1.3.27 is used from the original distro.

The following versions were used during build process:
lrwxr-xr-x   1 root   wheel   11 Oct 18 17:30 curl -> curl-7.19.0
drwxr-xr-x   6 root   wheel  512 Oct 18 17:34 curl-7.19.0
lrwxr-xr-x   1 root   wheel   10 Oct 19 20:21 imap -> imap-2006k
drwxr-xr-x   4 root   wheel  512 Oct 19 20:15 imap-2000b
drwxr-xr-x   4 root   wheel  512 Oct 19 20:29 imap-2006k
drwxr-xr-x   4 root   wheel  512 Oct 19 13:28 imap-2007b
lrwxr-xr-x   1 root   wheel   15 Oct 19 05:46 kerberos5 -> kerberos5-
1.6.3
drwxr-xr-x   8 root   wheel  512 Oct 19 06:05 kerberos5-1.6.3
lrwxr-xr-x   1 root   wheel   14 Oct 18 10:43 libxml2 -> libxml2-
2.6.32
drwxr-xr-x   6 root   wheel  512 Oct 18 16:01 libxml2-2.6.32
lrwxr-xr-x   1 root   wheel   12 Oct 18 08:06 mysql -> mysql-5.0.67
drwxr-xr-x  12 mysql  mysql  512 Oct 18 09:03 mysql-5.0.67
lrwxr-xr-x   1 root   wheel   13 Oct 18 20:42 openssl -> openssl-
0.9.7
drwxr-xr-x   6 root   wheel  512 Oct 18 20:50 openssl-0.9.7
drwxr-xr-x   6 root   wheel  512 Oct 18 14:42 php
lrwxr-xr-x   1 root   wheel   10 Oct 19 18:40 zlib -> zlib-1.2.3
drwxr-xr-x   5 root   wheel  512 Oct 19 18:41 zlib-1.2.3

I've tried imap both latest (2007b) and the one mentioned in http://php.net/manual/en/imap.setup.php (2000b). The latter even 
doesn't passes through PHP config-tests because of UTF-8, so I've 
tried also with 2006k - config-tests passed, make passed but no 
libphp5.so was generated during make install.

If i exclude "--with-imap-ssl=/opt/openssl --with-imap=/opt/imap"
from configure line and run:
# ./configure --prefix=/opt/php --with-apxs=/usr/sbin/apxs
--enable-mbstring --with-libxml-dir=/opt/libxml2 --with-
curl=/opt/curl --with-mysql=/opt/mysql --with-zlib=/opt/zlib --
without-iconv --without-pear --disable-dom --without-sqlite --
without-pdo-sqlite --with-kerberos=/opt/kerberos5 
...
# make
...
Build OK
...
# make install
everything works fine

Previously similar bug was submitted at http://bugs.php.net/bug.php?
id=29453 but marked as bogus.
 [2008-10-21 09:28 UTC] jani@php.net
Check that all the libraries you're linking with are shared ones.
And check the config.log (diff between working and non-working might help?).
 [2008-10-29 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jan 23 15:01:23 2021 UTC