php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4621 LDAP does not do anything
Submitted: 2000-05-26 20:19 UTC Modified: 2000-05-26 21:36 UTC
From: steve dot neuhart at webhelp dot com Assigned:
Status: Closed Package: LDAP related
PHP Version: 4.0.0 Release OS: RedHat 6.1
Private report: No CVE-ID: None
 [2000-05-26 20:19 UTC] steve dot neuhart at webhelp dot com
I configured php4 with....
 ./configure --with-apache=../apache_1.3.11 \
--with-ldap=../openldap-1.2.10 \
--with-imap=../imap-4.7a \
--with-mysql \
--with-gd \
--enable-track-vars 

I tried the following script....
<?php
echo "Connecting Ldap...";
$ds=ldap_connect("127.0.0.1");  

if ($ds) { 
    echo "connect result is ".$ds."\n";
} else {
    echo "Unable to connect to LDAP server";
}
?>

and get "Connecting Ldap...Unable to connect to LDAP server"

I've also tried linking to openLDAP 1.2.9... same thing. It worked fine under php3.0.14. Many people on the IMP mailing list are having the same problems. I've also run tcpdump and the query never hits the network. I'm at a loss.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-05-26 20:22 UTC] steve dot neuhart at webhelp dot com
sorry... my e-mail is "steve.neuharth@webhelp.com"
 [2000-05-26 21:36 UTC] steve dot neuhart at webhelp dot com
oops... forgot to "make distclean" after I configured php to not use the oracle crap.
ran make distclean on php and apache and reconfigured to NOT enable oracle in PHP and LDAP worked fine after that.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 01 10:03:34 2021 UTC