php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4616 Operators don't use decimals
Submitted: 2000-05-26 19:29 UTC Modified: 2000-05-26 19:42 UTC
From: cox at vulcanonet dot com Assigned:
Status: Closed Package: Scripting Engine problem
PHP Version: 4.0 Release Candidate 2 OS: Linux
Private report: No CVE-ID: None
 [2000-05-26 19:29 UTC] cox at vulcanonet dot com
In php3 I could do:
$foo = 10 + 0.25
(or any operator with decimals)
and the operation was good
$foo = 10.25
but with php4.0.0:
$foo = 10 !! no decimals!!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-05-26 19:42 UTC] hholzgra at cvs dot php dot net
this is

1) a duplicate of #4479 and #4605
2) already solved in latest cvs
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Fri Dec 06 13:01:23 2019 UTC