php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #46091 php.ini not found in C:\windows
Submitted: 2008-09-16 09:07 UTC Modified: 2008-09-25 15:20 UTC
From: linda_petty at shelter dot org dot uk Assigned:
Status: Not a bug Package: Windows Installer
PHP Version: 5.2.6 OS: windows 2003 SP2
Private report: No CVE-ID: None
 [2008-09-16 09:07 UTC] linda_petty at shelter dot org dot uk
Description:
------------
Installing AMP on windows 2003 (SP4).
I found a BUG in this version of the windows PHP,
apparently in the installer:
   PHP Version 5.2.6 (5.2 build 3790). 

We found the installation went fine on XP with this installer.
BUT on windows 2003 (SP2)I found these values on the PHPINFO page
after install:

   Configuration File (php.ini) Path: 	C:\WINDOWS
   Loaded Configuration File: 	        (none)        

PHP had IGNORED my PHP.ini file which, as instructed by the install 
documentation, I had carefully placed in C:\WINDOWS 

I found it would only load my php.ini file if I placed it in 
C:\PHP5 (which is the default install directory). 
Once the php.ini file was in C:\PHP5, after restarting Apache, 
at last I see:-

   Loaded Configuration File 	C:\PHP5\php.ini

quite a timewaster! :0)


Reproduce code:
---------------
install with Zip installer on windows 2003 (SP2)
using install directory C:\PHP
to reproduce the problem

Expected result:
----------------
I would have expected 
   Loaded Configuration File 	C:\WINDOWS\php.ini

Actual result:
--------------
   Loaded Configuration File: 	        (none) 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-09-25 13:54 UTC] linda_petty at shelter dot org dot uk
on the 1st line of description I said
windows 2003 (SP4)
I meant (SP2)
 [2008-09-25 15:20 UTC] tularis@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

Please read the manual:
http://www.php.net/manual/en/configuration.php
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Dec 08 07:03:33 2021 UTC