php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45946 table exist in the database, but mysql_query return false
Submitted: 2008-08-29 10:25 UTC Modified: 2008-08-29 23:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:0 of 1 (0.0%)
From: s_khreiss at hotmail dot com Assigned:
Status: Not a bug Package: *Database Functions
PHP Version: 5.2.6 OS: windows XP
Private report: No CVE-ID: None
 [2008-08-29 10:25 UTC] s_khreiss at hotmail dot com
Description:
------------
after connecting to my database using mysql_connect() and then select the database mysql_select_db("database_name"); mySql_query($qry); ($qry= "INSERT INTO $table...)  returns: database_name.$table
doesn't exist. but the table exist in the database.
in the database i have 20 tables, it doesn't work on 4 of  them and for the other it works properly. please if anyone can help me thankyou. PHP version 5.1.2, windows XP, wamp5 server.

Actual result:
--------------
query failed: database_name.table doesn't exist

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-29 23:11 UTC] tularis@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

PHP doesn't have any code which could influence this. Please try a mysql mailinglist / forum to help you find out what you're doing wrong.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 17:01:28 2020 UTC