php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #45929 fastcgi not documented, and confused with cli
Submitted: 2008-08-26 18:38 UTC Modified: 2009-11-20 13:30 UTC
Votes:4
Avg. Score:3.8 ± 1.3
Reproduced:2 of 2 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: atomo64 at gmail dot com Assigned:
Status: Closed Package: Documentation problem
PHP Version: Irrelevant OS:
Private report: No CVE-ID: None
 [2008-08-26 18:38 UTC] atomo64 at gmail dot com
Description:
------------
The -b option used for running the fastcgi server, is not documented 
in the manual pages.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-11-05 09:44 UTC] vrana@php.net
On which page this should be documented?
 [2008-11-11 16:23 UTC] kalle@php.net
Jakub, adding it on the features.commandline pages might be ideal where the other command line switches for using php on command line is :)
 [2009-09-09 03:15 UTC] philip@php.net
The CLI and CGI information differs, so this report is now specific to 
fastcgi. There are several directives that appear specific to CGI:

  -b <address:port>|<port> Bind Path for external FASTCGI Server mode
  -C               Do not chdir to the script's directory
  -q               Quiet-mode.  Suppress HTTP Header output.
  -T <count>   Measure execution time of script repeated <count> 
times.

And several are specific to CLI, or at least are not showing up in the 
CGI help (sapi/cgi/php -h):

  -r <code>        Run PHP <code> without using script tags <?..?>
  -B <begin_code>  Run PHP <begin_code> before processing input lines
  -R <code>        Run PHP <code> for every input line
  -F <file>        Parse and execute <file> for every input line
  -E <end_code>    Run PHP <end_code> after processing all input lines
  -H               Hide any passed arguments from external tools.
  -z <file>        Load Zend extension <file>.
  args...          Arguments passed to script. Use -- args when first 
argument
                   starts with - or script is read from stdin

  --ini            Show configuration file names

  --rf <name>      Show information about function <name>.
  --rc <name>      Show information about class <name>.
  --re <name>      Show information about extension <name>.
  --ri <name>      Show configuration for extension <name>.

So, I suppose it's time to make features.commandline CLI and something 
else for CGI (which is now always FastCGI).
 [2009-11-20 13:30 UTC] vrana@php.net
This bug has been fixed in the documentation's XML sources. Since the
online and downloadable versions of the documentation need some time
to get updated, we would like to ask you to be a bit patient.

Thank you for the report, and for helping us make our documentation better.


 [2009-11-20 13:32 UTC] svn@php.net
Automatic comment from SVN on behalf of vrana
Revision: http://svn.php.net/viewvc/?view=revision&revision=291081
Log: Document CGI options (bug #45929)
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Jul 31 04:01:24 2021 UTC