php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45911 Cannot disable ext/hash
Submitted: 2008-08-25 18:27 UTC Modified: 2008-09-07 13:17 UTC
From: hannes dot magnusson at gmail dot com Assigned:
Status: Closed Package: hash related
PHP Version: 5.3.0alpha1 OS: Linux
Private report: No CVE-ID:
 [2008-08-25 18:27 UTC] hannes dot magnusson at gmail dot com
Description:
------------
--disable-all doesn't disable ext/hash

Reproduce code:
---------------
./configure --disable-all

Actual result:
--------------
bjori@alba:/usr/src/php/5.3$ sapi/cli/php -m
[PHP Modules]
date
ereg
hash
pcre
Reflection
SPL
standard


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-25 18:39 UTC] jani@php.net
Yes, it's a mess. ext/hash should be enabled if ext/mhash is (or not?) and it's not really possible since m comes after h.. :)

IMO: Make ext/mhash RIP. Providing an extension JUST that someone can do 'if extension mhash exists..' is simply ridiculous..

Is renaming some functions that hard in scripts..?!
 [2008-09-07 13:17 UTC] lbarnaud@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2014 The PHP Group
All rights reserved.
Last updated: Fri Apr 18 15:02:26 2014 UTC