php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #45856 sqlite3 extension: sqlite_num_rows missing
Submitted: 2008-08-19 03:56 UTC Modified: 2018-07-08 19:11 UTC
Votes:1
Avg. Score:3.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: roberto at spadim dot com dot br Assigned: cmb (profile)
Status: Wont fix Package: SQLite related
PHP Version: 5.3.0alpha1 OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: roberto at spadim dot com dot br
New email:
PHP Version: OS:

 

 [2008-08-19 03:56 UTC] roberto at spadim dot com dot br
Description:
------------
i'm using today sqlite2, the problem is, i don't found some functions like:
sqlite_num_rows
maybe SQLite3_result class should add this function, i know that have some problem because it maybe unbuffered, but when this functions is called the extension could buffer the result and use it, or when we use query function of sqlite3 class a parameter should be unbuffered / buffered
i don't know, but this is a problem, i found this in PDO too, what i do? i put all result in a array (this is slower than in C)
maybe a performace insue could be done with this

thanks
roberto spadim

Reproduce code:
---------------
nothing

Expected result:
----------------
feature request


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-19 14:56 UTC] scottmac@php.net
It's hard to do lazy loading, for example you read 10 rows then fetch 
the number of rows and it reads the next 2. So keeping tabs of previous 
rows would be required.

Doing a buffered result set from the start is possible but you need to 
store lots more metadata so that other functions will work correctly.

I don't have an intention of adding a buffered result class as it just 
complicates the code, You could modify your code and add COUNT(*) AS 
total or preload the code.

 [2018-07-08 19:12 UTC] cmb@php.net
-Summary: sqlite3 extension, some functions not found +Summary: sqlite3 extension: sqlite_num_rows missing -Status: Suspended +Status: Wont fix -Package: Feature/Change Request +Package: SQLite related -Assigned To: +Assigned To: cmb
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 07 03:01:23 2020 UTC