php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45825 No message displayed for parse errors in included files
Submitted: 2008-08-14 18:52 UTC Modified: 2008-08-14 19:11 UTC
From: a at a dot com Assigned:
Status: Wont fix Package: Scripting Engine problem
PHP Version: 4.4.8 OS: WinXP
Private report: No CVE-ID: None
Have you experienced this issue?
Rate the importance of this bug to you:

 [2008-08-14 18:52 UTC] a at a dot com
Description:
------------
WinXP, IIS, ISAPI, PHP 4.4.8 (I have to use the 4.x branch because my code needs to run on a shared hosting server that I have no control over, and they only have the 4.x branch.)

When there is a parse error in an included file, NO error is displayed even if display_errors and error_reporting are set correctly.

Reproduce code:
---------------
--a.php--
<?php
ini_set('display_errors', 1);
error_reporting(E_ALL & E_NOTICE);
include("b.inc.php");
?>
---------

--b.inc.php--
<?php
ini_set('display_errors', 1);
error_reporting(E_ALL & E_NOTICE);
$testvar = ;
?>
-------------

Expected result:
----------------
Parse error: syntax error, unexpected ';' in [path here]\b.inc.php on line 4

Actual result:
--------------
The output is absolutely, completely blank.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-14 19:11 UTC] jani@php.net
We are sorry, but we can not support PHP 4 related problems anymore.
Momentum is gathering for PHP 6, and we think supporting PHP 4 will
lead to a waste of resources which we want to put into getting PHP 6
ready.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sun Aug 14 00:05:44 2022 UTC