php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45800 cannot compile PHP with http on osx
Submitted: 2008-08-12 13:43 UTC Modified: 2008-08-12 13:49 UTC
From: dams@php.net Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 5.3.0alpha1 OS: osx 10.4
Private report: No CVE-ID: None
 [2008-08-12 13:43 UTC] dams@php.net
Description:
------------
When compiling PHP with --enable-http, I get this error : 

In file included from /Users/macbook/bin/php5.3-
200808111430/ext/http/http.c:26:
/Users/macbook/bin/php5.3-200808111430/ext/http/php_http_api.h: In 
function '_zval_copy':
/Users/macbook/bin/php5.3-200808111430/ext/http/php_http_api.h:299: 
error: 'struct _zval_struct' has no member named 'refcount'
/Users/macbook/bin/php5.3-200808111430/ext/http/php_http_api.h:300: 
error: 'struct _zval_struct' has no member named 'is_ref'
make: *** [ext/http/http.lo] Error 1





Reproduce code:
---------------
./configure --enable-http & make



Expected result:
----------------
PHP compile correctly with the http extension.

Actual result:
--------------
Compilation fails. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-08-12 13:49 UTC] lstrojny@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

You are trying to compile ext/http from PECL and you encountered a bug related to pecl-http and not to PHP itself. Please report a bug on http://pecl.php.net/bugs/
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Aug 03 08:01:25 2021 UTC