php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #4569 configure fails to correctly identify GD 1.8.x functions available
Submitted: 2000-05-24 04:19 UTC Modified: 2000-09-22 07:23 UTC
From: achowe at snert dot com Assigned:
Status: Closed Package: *General Issues
PHP Version: 4.0.0 Release OS: Linux RH 6.1
Private report: No CVE-ID: None
 [2000-05-24 04:19 UTC] achowe at snert dot com
(Problem also exists with 3.0.16)

I installed gd 1.8.2, libpng 1.0.9, zlib 1.1.3, jpeg 6b, compiled and installed into the default locations.

However, everytime I run PHP configure, it fails to find :

gdImageColorResolve 
gdImageCreateFromPng
gdImageCreateFromJpeg 

I stumbled across this yesterday when building PHP 3.0.16 and found duplicate symbols that were defined
both in PHP and GD.  Downloading PHP 4.0.0 today, I still find the problem.

My work around was to modify config.h and define explicitly by hand :

#define HAVE_GD_PNG  1
#define HAVE_GD_JPG 1
#define HAVE_GD_COLORRESOLVE 1

And modify the Makefile macro APXS_LDFLAGS to add : -ljpeg -lpng



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2000-08-01 21:49 UTC] hholzgra@php.net
looks like you have parts from an old gd installation 
left over somewhere ???
 [2000-08-02 10:41 UTC] stas@php.net
Confirmed - it happens to me too, on RH 6.1 gd 1.8.1 installation. Configure seems to try and conpiled GD without linking libgpng, libz and a dozen of other libraries that RedHat GD installation needs to be linked. 
 [2000-08-02 17:26 UTC] stas@php.net
You may want to try GD 1.8.3 RPMs from http://rufus.w3.org/linux/RPM/ - they work for me. I still believe this should be fixed (i.e., one doesn't need to link GD to check if we have libz and libpng).
 [2000-09-22 07:23 UTC] sniper@php.net
This should be fixed. If not, please reopen.

--Jani
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC