php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45657 header() problem with special chars: ?, ? and ?
Submitted: 2008-07-29 19:27 UTC Modified: 2008-07-29 20:11 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:1 (100.0%)
Same OS:0 (0.0%)
From: jakob at skatetown dot dk Assigned:
Status: Not a bug Package: HTTP related
PHP Version: 4.4.8 OS: Linux
Private report: No CVE-ID: None
 [2008-07-29 19:27 UTC] jakob at skatetown dot dk
Description:
------------
The header function dont work with international characters lik: ?, ? and ?.
It replace them with %f8 and stuff like that.
ex: header("Location: http://www.uddannelsesst?tte.dk");

http://www.uddannelsesst?tte.dk is a danish site, that helps students finding money.

Reproduce code:
---------------
header("Location: http://www.uddannelsesst?tte.dk");

Expected result:
----------------
Redirected to the site "http://www.uddannelsesst?tte.dk"

Actual result:
--------------
Broser output:
Couldn't find http://www.uddannelsesst%f8tte.dk

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-29 19:28 UTC] jakob at skatetown dot dk
This is pretty urgent, cause Denmark has just released domain names with ?, ? and ?.
 [2008-07-29 20:05 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

You have to use the IDN version of the domain name: http://mct.verisign-grs.com/conversiontool/convertServlet?input=www.uddannelsesst?tte.dk&type=UTF8 (pick the punycode one). Firefox properly re-codes that to http://www.uddannelsesst?tte.dk.
 [2008-07-29 20:11 UTC] jakob at skatetown dot dk
This is NOT a support question!
It's a bug...!
No servers can handle it.
It's not "wrong setup".
Its the function it's wrong with.. :S
No i've had to make a HTML redirect, and that's not optimal!
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Feb 23 15:01:26 2020 UTC