php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45655 result of crypt() without salt is always empty
Submitted: 2008-07-29 13:09 UTC Modified: 2008-07-30 14:44 UTC
From: iver at jackewitz dot de Assigned: pajoye (profile)
Status: Not a bug Package: *Encryption and hash functions
PHP Version: 5.2.6 OS: ubuntu 8.04
Private report: No CVE-ID: None
 [2008-07-29 13:09 UTC] iver at jackewitz dot de
Description:
------------
Desc:
result of crypt() without salt is always empty

PHP-Version:
- 5.2.4
- 5.2.6

5.2.3 it's okay

Reproduce code:
---------------
echo(crypt('Hallo'));

Expected result:
----------------
1rwefw34rf2345wer # something like that


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-29 13:43 UTC] pajoye@php.net
It really depends of which libc you use, and if you have the right algorithm present. If MD5 and DES are not present, them it is expected.

Please try using PHP 5.3 snapshot, all algorithms are now available, no matter which libc you use (or not).
 [2008-07-30 13:52 UTC] iver at jackewitz dot de
Well, it's not a PHP-Bug, but a php5-suhosin bug in the version 0.9.22. This bug is fixed in 0.9.23. see: http://www.hardened-php.net/suhosin/changelog.html
 [2008-07-30 14:44 UTC] pajoye@php.net
You don't need suhosin extension anymore to solve crypt's issues (the patch itself is still fine) as we use the same blowfish implementation (from Solar Designer/openwall) and everything is enabled by default when the system is outdated. However it is still not a bug  > bogus
 
PHP Copyright © 2001-2018 The PHP Group
All rights reserved.
Last updated: Fri Sep 21 19:01:25 2018 UTC