php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45574 $_POST error, 1st variable overflow, system overloads
Submitted: 2008-07-21 01:03 UTC Modified: 2008-07-21 06:51 UTC
From: ccooper at lightoflife dot org Assigned:
Status: Not a bug Package: IIS related
PHP Version: 5.2.6 OS: Windows Server 2003
Private report: No CVE-ID: None
 [2008-07-21 01:03 UTC] ccooper at lightoflife dot org
Description:
------------
Creating a purchase order system for my company, I needed to create pages that captured as many as 100 input fields (mostly text) per form submit. Doing so, The first post variable would have a key corruption and the IIS Services would need to be reset (either that or wait about 30 minutes for php to be able to accept any type of user input again).

I have found the solution, finally, to be in the php.ini file.  Though in 5.0 max_input_nesting_level  was omitted by ;   , a change from 4.0, yet there is still a default of 60 if you look at phpinfo with ;max_input_nexting_level = 60  in the file. The ; isn't enough and it's not enough to set it to 0, I had to set it to an absurdly large number (I used 300).  I'm leaving this because it's still a bug and someone needs to know about this.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-21 06:51 UTC] jani@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 08 11:03:42 2023 UTC