php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45499
Submitted: 2008-07-13 11:21 UTC Modified: 2008-07-13 14:57 UTC
From: lwx0108 at gmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.6 OS: ubuntu
Private report: No CVE-ID: None
 [2008-07-13 11:21 UTC] lwx0108 at gmail dot com
Description:
------------
when i conert langer than 2147483647(0x6fffffff) use decbin will return 32's 1

Reproduce code:
---------------
<?php
$shmKey = ftok(__FILE__, 'c');
$pid    = posix_getpid();
if ($shmKey) {
>---$shmId = shmop_open($shmKey, 'c', 0775, 32);
>---$w     = shmop_write($shmId, 0x7fffffff, 0);
>---$r     = shmop_read($shmId, 0, 32);
>---$d     = shmop_delete($shmId);
>---echo $r . "\n";
>---echo decbin($r);
}
?>



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-13 14:57 UTC] jani@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 06:05:44 2022 UTC