|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45402 Call to undefined function sybase_connect()
Submitted: 2008-07-01 14:02 UTC Modified: 2008-07-14 18:59 UTC
From: fborot at hotmail dot com Assigned:
Status: Closed Package: Sybase (dblib) related
PHP Version: 5.2.6 OS: redhat
Private report: No CVE-ID: None
 [2008-07-01 14:02 UTC] fborot at hotmail dot com
I compiled php 5 with sybase support ,[./configure --prefix=/usr/local/php5 --with-mysql=/usr/bin/mysql --with-sybase=/opt/sybase-11.9.2/OCS-15_0/] now when I run this script 
// create connection
$connection = sybase_connect("ip","user","passwd");

// test connection
if (!$connection) {
echo "Couldn't make a connection!";

the browser shows 
Fatal error: Call to undefined function sybase_connect() in /usr/local/apache2/htdocs/scon.php on line 4


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-01 14:30 UTC]
Not enough information was provided for us to be able
to handle this bug. Please re-read the instructions at

If you can provide more information, feel free to add it
to this bug and change the status back to "Open".

Thank you for your interest in PHP.

Please check the output of phpinfo() to see whether sybase support was laoded, if it's missing check the configure line mentioned on top of that page and check configure.log in your build directory.
 [2008-07-01 14:59 UTC] fborot at hotmail dot com
how can upload the output of phpinfo()

it is very weird, I just deleted config.cache, the old Makefile, from the building directory and re-compiled again with the same options,

--prefix=/usr/local/php5 --with-mysql=/usr/bin/mysql

but phpinfo() shows:

Configure Command 	 './configure' '--with-mysql=/usr/bin/mysql' '--with-apxs2=/usr/local/apache2/bin/apxs' '--with-unixODBC=shared,/usr/local/easysoft/unixODBC'

magic_quotes_sybase	Off	Off
SYBASE 	/opt/sybase-11.9.2
_ENV["SYBASE"]	/opt/sybase-11.9.2

which should not be, I tried 2 days ago to use the odbc driver provided by easysoft because with-sybase-ct and with-sybase it would not compile.
I guess I should delete the odbc driver and try again, I would like to attach some files/logs here but don't see how

 [2008-07-01 15:40 UTC] fborot at hotmail dot com
I deleted everything related to easysoft odbc driver,deleted the php installation again, the config.cache on the build directory,ran make clean and make distclean, remove the old Makefile and compiled it again and phpinfo() shows support for odbc instead of sybase.

what is happening here? what files do you need me to send/upload?
this is very frustrating
 [2008-07-02 09:18 UTC]
Please try with totally fresh sources. And run the commands in the source directory. You also need to install the compiled binaries. I bet you're just seeing the old installation.
 [2008-07-02 13:17 UTC] fborot at hotmail dot com
txs for the reply

I will download again the php sources, and delete the current one.

I always run the commands [configure, make , make install] in the source directory.
What do you mean by "You also need to install the compiled binaries."

what do you recomend as far as Apache:
1- remove it and install it again
   1.1 compile apache with php 
   1.2 compile apache and load php later

 [2008-07-13 15:01 UTC]
To install binaries you say:

# make install

And please don't change the status back to open or add any more irrelevant comments. We're only interested whether it worked or not. And if not why.
 [2008-07-14 18:59 UTC] fborot at hotmail dot com
there was another php installed on the machine, I tried on a different machine and it works
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Jun 24 14:01:29 2024 UTC