php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45140 imap_search() does not support OR
Submitted: 2008-05-31 03:17 UTC Modified: 2008-06-06 09:47 UTC
From: sireland at byrequest dot com Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 5.2.6 OS: Fedora
Private report: No CVE-ID: None
 [2008-05-31 03:17 UTC] sireland at byrequest dot com
Description:
------------
imap_search($mbox, "OR (TEXT name1) (TEXT name2)") returns "Unknown search criterion:"

Z SEARCH OR (TEXT name1) (TEXT name2) works when typed directly into Cyrus IMAP Server 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-06 09:47 UTC] jani@php.net
That's because the c-client doesn't support it. Check your c-client version and then report this to the author of it, http://www.washington.edu/imap/ might help.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Tue Jan 31 17:05:53 2023 UTC