php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45096 Unsuccessful installation
Submitted: 2008-05-26 18:38 UTC Modified: 2008-08-22 18:24 UTC
From: zoran dot horvat at finsoft dot co dot yu Assigned: jmertic (profile)
Status: Not a bug Package: Windows Installer
PHP Version: 5.2.6 OS: Win Vista Home Premium, WinXP
Private report: No CVE-ID: None
 [2008-05-26 18:38 UTC] zoran dot horvat at finsoft dot co dot yu
Description:
------------
In relation to bug report #45061, I had exactly the same symptoms. 

I have run php-5.2.6-win32-installer.msi with administrative privileges and installed PHP to C:\Program Files\PHP. Installation apparently passed well, but php.exe reported number of DLLs missing. 

After that I have uninstalled PHP and re-installed it in D:\PHP, again with administrative privileges. This installation went well and php.exe works fine. My impression is that a blank space in Program Files directory makes setup to fail.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-06-03 14:39 UTC] jmertic@php.net
It sounds like you tried to do a full install, this is not recommended since many of the extensions have DLLs that are required for proper functionality. Instead, only enable the extensions you need.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Dec 06 09:03:34 2021 UTC