php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45091 Startup errors
Submitted: 2008-05-26 13:57 UTC Modified: 2008-08-22 18:24 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:2 (100.0%)
Same OS:1 (50.0%)
From: jorgenhagglund at netscape dot net Assigned: jmertic (profile)
Status: Closed Package: Windows Installer
PHP Version: 5.2.6 OS: Windows Server 2003 SP2
Private report: No CVE-ID: None
 [2008-05-26 13:57 UTC] jorgenhagglund at netscape dot net
Description:
------------
Clean install on a fairly clean system.
Some modules active.
Running PHP.exe from command line gives a list of error messages like this: 
Cannot find module (IP-MIB): At line 0 in (none)
Cannot find module (IF-MIB): At line 0 in (none)
Cannot find module (TCP-MIB): At line 0 in (none)
Cannot find module (UDP-MIB): At line 0 in (none)
Cannot find module (SNMPv2-MIB): At line 0 in (none)
Cannot find module (SNMPv2-SMI): At line 0 in (none)
Cannot find module (UCD-SNMP-MIB): At line 0 in (none)
Cannot find module (UCD-DEMO-MIB): At line 0 in (none)
Cannot find module (SNMP-TARGET-MIB): At line 0 in (none)
Cannot find module (SNMP-VIEW-BASED-ACM-MIB): At line 0 in (none)
Cannot find module (SNMP-COMMUNITY-MIB): At line 0 in (none)
Cannot find module (UCD-DLMOD-MIB): At line 0 in (none)
Cannot find module (SNMP-FRAMEWORK-MIB): At line 0 in (none)
Cannot find module (SNMP-MPD-MIB): At line 0 in (none)
Cannot find module (SNMP-USER-BASED-SM-MIB): At line 0 in (none)
Cannot find module (SNMP-NOTIFICATION-MIB): At line 0 in (none)
Cannot find module (SNMPv2-TM): At line 0 in (none)

I have tried uninstalling then installing the version from the web site (as of May 26, 2008 version php-5.2.6-win32-installer.msi) without success.
I then tried "upgrading" to the latest snap (php5.2-win32-latest.zip), still no success.




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-26 19:58 UTC] jani@php.net
Apparently the installer does not install everything, in this case some snmp part is missing: http://www.php.net/manual/en/snmp.installation.php

Assigned to the installer maintainer.
 [2008-05-27 11:01 UTC] jorgenhagglund at netscape dot net
Obviously, that's the problem, as it disappears when I disable the SNMP module, but Your link to the "solution" is a bit questionable.
That speaks of a recompile, which I'm not too comfortable with (and, honestly, sounds more like a solution for non-Windows-users).
I've grown accustomed to the simplicity by just adding modules (dll's).
So, I guess it's just for me to wait for a proper release?
 [2008-06-01 07:58 UTC] dolle at xs4all dot nl
I am getting the same errors on a Windows 2000 server... after updating from PHP 4 to PHP 5.2.1 then to 5.2.5 and then to 5.2.6


even after making sure all was gone... and a reinstall.. all was gone... removing the SNMP module did help.. error gone.. but guess not the final solution
 [2008-07-10 19:31 UTC] jmertic@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.

Made sure that the SMNP support files get installed in the usr/mibs directory in the root directory.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jul 01 23:05:45 2022 UTC