php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #45064 Not able to open Msword in Ubuntu
Submitted: 2008-05-22 09:52 UTC Modified: 2008-05-22 10:54 UTC
From: maniviswa at gmail dot com Assigned:
Status: Not a bug Package: Compile Warning
PHP Version: 5.2.6 OS: Ubuntu
Private report: No CVE-ID: None
 [2008-05-22 09:52 UTC] maniviswa at gmail dot com
Description:
------------
Im using this code,
<?php
$comObject = new COM("Word.Application");
?>
~                                                                                                                                                            
~          
But im getting error like this,what might be the problem
error is Fatal error: Class 'COM' not found in /opt/lampp/htdocs/word/example.php on line 2

Reproduce code:
---------------
<?php
$comObject = new COM("Word.Application");
?>
~     

Expected result:
----------------
/opt/lampp/htdocs/word/example.php on line 2

Actual result:
--------------
A plain Msword Document

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-22 10:38 UTC] pajoye@php.net
COM is windows only, see the manual for further info.
 [2008-05-22 10:54 UTC] sthulbourn@php.net
Well, the problem is, you're trying to open MICROSOFT WORD in Linux 
using a Windows only extension.

A quick fix: Install windows.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sun Nov 29 08:01:23 2020 UTC