php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44937 Warning: ldap_bind() [function.ldap-bind]: Unable to bind to server: Out of mem
Submitted: 2008-05-07 18:49 UTC Modified: 2013-10-16 04:25 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:2 of 2 (100.0%)
Same Version:1 (50.0%)
Same OS:0 (0.0%)
From: aalvarez at n2bsolutions dot com Assigned: sixd (profile)
Status: Closed Package: OCI8 related
PHP Version: 5.2.6 OS: Ubuntu 7.10
Private report: No CVE-ID: None
 [2008-05-07 18:49 UTC] aalvarez at n2bsolutions dot com
Description:
------------
I have Apache2.2.6 running php5.2.6 with support for:

CFLAGS=' -O3 -I/usr/src/instantclient_11_1/sdk/include -I/usr/lib32 -I/usr/include -I/usr/include/sasl' \
CXXFLAGS='-I/usr/src/instantclient_11_1/sdk/include -I/usr/lib32 -I/usr/include -I/usr/include/sasl' \
'./configure' \
'--includedir=/usr/src/instantclient_11_1/sdk/include' \
'--includedir=/usr/src/instantclient_11_1/sdk' \
'--with-oci8=/usr/src/instantclient_11_1/' \
'--with-jpge' \
'--with-jpeg-dir' \
'--with-pgsql' \
'--with-gd' \
'--with-png-dir' \
'--with-zlib-dir' \
'--with-apxs2=/usr/local/apache226/bin/apxs' \
'--with-openssl' \
'--with-openssl' \
'--with-tiff' \
'--without-pdo-oci' \
'--enable-sigchild' \
'--enable-soap' \
'--enable-ftp' \
'--with-curl' \
'--with-curlwrappers' \
'--with-ldap' \
'--with-ldap-sasl'
"$@"

I know where is the problem but i don?t know how to fix it...

When i change ennvars like that disabling Oracle oci8 lib
all works perfectly :-/

LD_LIBRARY_PATH="/usr/local/apache226/lib:/usr/lib:$LD_LIBRARY_PATH"
export LD_LIBRARY_PATH
export ORACLE_HOME=/usr/src/instantclient_11_1
#export TNS_ADMIN=$ORACLE_HOME/network/admin
#export TWO_TASK=$ORACLE_HOME/network/admin/tnsnames.ora
export ORACLE_SID=XE
export LD_PRELOAD=/usr/lib/libldap.so:/usr/lib/libldap_r.so:/usr/lib/sasl2/libldapdb.so:/usr/lib32/libldap.so.2:
#$ORACLE_HOME/lib/libclntsh.so
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:$ORACLE_HOME/lib
export NLS_LANG=AMERICAN_AMERICA.WE8MSWIN1252

It doesn?t matter if i load first the libldap.so ....

Any Ideas?
Thxs a lots


Reproduce code:
---------------
Warning: ldap_bind() [function.ldap-bind]: Unable to bind to server: Out of memory in /home/www/web1/web/ss_dev/__fvalida.php


Expected result:
----------------
Ok if the user have valid password in may OpenLDAP 2.2.3 server
it works without oracle LD_PRELOAD but ... i need it too :-(




Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-09 14:36 UTC] jani@php.net
Oracle libs used to have their own implementation for ldap funcs. 
So I guess you just need to compile PHP ldap extension to use those libs instead of openldap. I don't know if that instant client thing has the same issue, so assigning to the Oracle guru. :)
 [2008-05-10 07:50 UTC] aalvarez at n2bsolutions dot com
Ok, I will try to compile with the ldap lib for oracle.
Now i have two apache+php working together :-/ one with oci8 and another 
one with ldap ....

Thxs!
 [2012-10-26 06:03 UTC] sixd@php.net
-Status: Assigned +Status: Suspended -Package: LDAP related +Package: OCI8 related
 [2012-10-26 06:03 UTC] sixd@php.net
See https://github.com/php/php-src/pull/19

I'm suspending this bug pending the merge of that patch.
 [2013-10-16 04:25 UTC] sixd@php.net
-Status: Suspended +Status: Closed
 [2013-10-16 04:25 UTC] sixd@php.net
The configuration changes in https://github.com/php/php-src/pull/19 have been merged. However I still recommend building PHP without OCI8, and then adding it as a shared extension.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Oct 06 17:05:51 2022 UTC