php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44922 After update from 5.2.5 to 5.2.6 postgrest doesn't work
Submitted: 2008-05-06 01:03 UTC Modified: 2008-05-06 16:53 UTC
From: gabriel dot vasquez at gmail dot com Assigned:
Status: Not a bug Package: PostgreSQL related
PHP Version: 5.2.6 OS: Windows XP SP2
Private report: No CVE-ID: None
 [2008-05-06 01:03 UTC] gabriel dot vasquez at gmail dot com
Description:
------------
After update from PHP version 5.25 to 5.2.6 my system didn't work, i get a message 

[Mon May 05 21:53:31 2008] [error] [client 189.26.101.57] PHP Fatal error:  Call to undefined function pg_connect() in C:\\apache\\Laboratorio\\lab\\conectadb.php on line 8


I started to digg and i've found that the newer version of php_pgsql.dll has 96kb, and the older has 164kb.

I've updated using the instaler for windows 32bit, an MSI file that i've downloaded from PHP.net, actually i'm using Windows XP SP2 all updated.Link: http://br.php.net/distributions/php-5.2.6-win32-installer.msi

I fixed the problem downgrading the php_pg_sql.dll to the one contained in the version 5.25.

I have both DLL if someone need it.

Sorry for my poor english.
Gabriel - Londrina - Parana - Brazil.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-06 16:53 UTC] iliaa@php.net
Please do not submit the same bug more than once. An existing
bug report already describes this very problem. Even if you feel
that your issue is somewhat different, the resolution is likely
to be the same. 

Thank you for your interest in PHP.

Dupe of bug #44905
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri May 24 20:01:29 2024 UTC