php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44920 "vsprintf_variation8.phpt" from "make test" depends on precision
Submitted: 2008-05-05 21:46 UTC Modified: 2008-05-05 23:05 UTC
From: twm at twmacinta dot com Assigned:
Status: Closed Package: Unknown/Other Function
PHP Version: 5.2.6 OS: Red Hat Enterprise Linux ES 3
Private report: No CVE-ID: None
 [2008-05-05 21:46 UTC] twm at twmacinta dot com
Description:
------------
After building PHP 5.2.6 on RHEL3, I ran "make test" to test the new build, and one of the tests that failed was "vsprintf_variation8.phpt".  I inspected the test's output, compared it to what was expected, tracked down the problem, and came up with a potential fix for it.

The problem appears to be that the expected output of the test is based on the default "precision" configuration setting of 14, but my "php.ini" file has it set to 12.  This looks like it is the same problem that occurred with the "make test" script "ext/json/tests/bug41567.phpt", which was fixed in revision "1.1.2.5".  The fix was simply to specify the precision in an INI section.  When I apply this same fix to "vsprintf_variation8.phpt", the test then passes.  Here's what I added:

--INI--
precision=14

I had copied the file named "php.ini-dist" which came with the PHP source distribution to "/etc/php.ini", without modification.  It sets the precision to 12.

I looked at the CVS history for the test "vsprintf_variation8.phpt" and it appears to be fixed in PHP 5.3 in the same way I suggested above.  I think that fix just needs to be applied to PHP 5.2 as well.


Reproduce code:
---------------
1) Copy "php.ini-dist", which comes with PHP, to "/etc/php.ini"

2) Run the test that comes with PHP: "ext/standard/tests/strings/vsprintf_variation8.phpt" 


Expected result:
----------------
Number of tests :    1                 1
Tests skipped   :    0 (  0.0%) --------
Tests warned    :    0 (  0.0%) (  0.0%)
Tests failed    :    0 (  0.0%) (  0.0%)
Tests passed    :    1 (100.0%) (100.0%)


Actual result:
--------------
Number of tests :    1                 1
Tests skipped   :    0 (  0.0%) --------
Tests warned    :    0 (  0.0%) (  0.0%)
Tests failed    :    1 (100.0%) (100.0%)
Tests passed    :    0 (  0.0%) (  0.0%)


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-05-05 23:05 UTC] iliaa@php.net
This bug has been fixed in CVS.

Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
 
Thank you for the report, and for helping us make PHP better.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Mon Aug 10 16:01:23 2020 UTC