php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44886 output_add_rewrite_var fails on <form> with attributes containing underscores
Submitted: 2008-05-01 22:28 UTC Modified: 2008-07-15 00:12 UTC
From: suhachov at gmail dot com Assigned:
Status: Not a bug Package: Output Control
PHP Version: 5.2.5 OS: *
Private report: No CVE-ID: None
 [2008-05-01 22:28 UTC] suhachov at gmail dot com
Description:
------------
output_add_rewrite_var() fails to operate on forms with attributes containing underscores:
<form _url="..">...</form>

The reason is that only a-zA-Z are allowed in attribute names:
ext/standard/url_scanner_ex.re, lines 310-...:
state_arg:
	start = YYCURSOR;
/*!re2c
  alpha alphadash*	{ passthru(STD_ARGS); handle_arg(STD_ARGS); STATE = STATE_BEFORE_VAL; goto state_before_val; }
  any		{ passthru(STD_ARGS); STATE = STATE_NEXT_ARG; goto state_next_arg; }
*/

and alpha is:
alpha = [a-zA-Z];


I know that _ is not a character that is used in any standard html attributes, but it's used sometimes in the dojo world.



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-07-15 00:12 UTC] jani@php.net
Thank you for taking the time to write to us, but this is not
a bug. Please double-check the documentation available at
http://www.php.net/manual/ and the instructions on how to report
a bug at http://bugs.php.net/how-to-report.php


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed May 18 09:04:05 2022 UTC