php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44853 filter_callback crash
Submitted: 2008-04-28 10:14 UTC Modified: 2009-07-04 15:42 UTC
From: vtsupermok at gmail dot com Assigned:
Status: Closed Package: Filter related
PHP Version: 5.2.5 OS: Win Vista
Private report: No CVE-ID: None
 [2008-04-28 10:14 UTC] vtsupermok at gmail dot com
Description:
------------
In a filter_callback function, if the function return false, the system crash, the apache hange.

if return other things other than false, for example 'aaa',true,1, it works

Reproduce code:
---------------
function returnTrue($val){
    return true;
}

function returnFalse($val){
    return false;
}

var_dump(filter_var('aaaa', FILTER_CALLBACK, array("options"=>"returnTrue")));

var_dump(filter_var('aaaa', FILTER_CALLBACK, array("options"=>"returnFalse")));

Expected result:
----------------
bool(true)
bool(false)

Actual result:
--------------
nothing can see, because the system crashed

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-29 09:51 UTC] vtsupermok at gmail dot com
I just try the latest window version but it still not work. The result also same with before
 [2008-04-29 11:40 UTC] felipe@php.net
This bug was fixed in PHP 5.2.6RC1. Make sure the version used in your test. (see the php version)
I can't reproduce on PHP 5.2.6RC6-dev.
 [2008-05-07 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 14:03:37 2021 UTC