php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44831 Injection By Executing of External Scripts
Submitted: 2008-04-25 11:32 UTC Modified: 2008-04-25 13:31 UTC
From: yasenpetrov at gmail dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.4.8 OS: Linux
Private report: No CVE-ID: None
 [2008-04-25 11:32 UTC] yasenpetrov at gmail dot com
Description:
------------
Hello,

I'm having a similar problem like the one this guy is describing. My website gets infected somehow. I've tried to delete .htaccess file that causes the redirection, the directory with the malicious files, change the FTP password. It is ok for a day or two but then these files get recreated somehow.

I'm going to try the steps described in this article and the link within. 

Just thought you may want to know (if you do not know already) this case. I am sure a lot of websites are affected by this "virus" or whatever is called. 

The main point is that when a user clicks on a link from Google (or other search engine) results on a certain infected website they see some blog page and get redirected to AdultFriendFinder in a few seconds instead of visiting the real website.

It is quite hard to get rid of this virus and also hard to find info in internet about this issue. I've been trying to solve this problem for over a month now. The hosting provider just told me: "Examine the log files". It is a real pain in the but for nub cakes like me ^^

Thank you.

Yasen

PS. I know my English sucks but hope you understood me.

Reproduce code:
---------------
http://groups.google.com/group/Google_Web_Search_Help-UsingWS/browse_thread/thread/7ac29a38008c4d81


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-25 13:31 UTC] scottmac@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Feb 28 07:01:28 2020 UTC