php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44788 Some PHP extensions will not load
Submitted: 2008-04-20 15:22 UTC Modified: 2008-04-20 21:32 UTC
From: cormac at kernan dot eu Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 5.2.5 OS: Vista Ultimate SP1
Private report: No CVE-ID: None
 [2008-04-20 15:22 UTC] cormac at kernan dot eu
Description:
------------
Cannot get some extensions to load with PHP 5.2.5 on Apache 2.2.6 or 2.2.8 on Windows Vista Ultimate SP1 (32 bit).

phpinfo() shows that the php.ini file is being found and that the following extensions load as expected:

php_gd2.dll
php_mbstring.dll
php_soap.dll
php_pdo.dll

However, the following do not load:

php_mysql.dll
php_mysqli.dll
php_pdo_mysql.dll

I have tried loading each of these on their own, but the Apache error log always shows the same result i.e. the extensions do not load.  MySQL is installed correctly and I have had the same setup working without problem on Vista 64 bit and Vista 32 bit (without SP1).  I have tried the latest PHP 5.2 snapshot, only to get the same result.

Reproduce code:
---------------
Add the following to php.ini ensuring that all required extensions are present in the extensions directory:

extension=php_gd2.dll
extension=php_mbstring.dll
extension=php_soap.dll
extension=php_pdo.dll
extension=php_mysql.dll
extension=php_mysqli.dll
extension=php_pdo_mysql.dll

Expected result:
----------------
All extensions should load as required with no errors in Apache error log after startup.

Actual result:
--------------
Apache error log shows something similar to the following:

PHP Warning:  PHP Startup: Unable to load dynamic library 'C:/php/ext/php_mysqli.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Sun Apr 20 15:38:00 2008] [notice] Apache/2.2.6 (Win32) PHP/5.2.5 configured -- resuming normal operations
[Sun Apr 20 15:38:00 2008] [notice] Server built: Sep  5 2007 08:58:56
[Sun Apr 20 15:38:00 2008] [notice] Parent: Created child process 5240
PHP Warning:  PHP Startup: Unable to load dynamic library 'C:/php/ext/php_mysqli.dll' - The specified module could not be found.\r\n in Unknown on line 0
[Sun Apr 20 15:38:00 2008] [notice] Child 5240: Child process is running
[Sun Apr 20 15:38:00 2008] [notice] Child 5240: Acquired the start mutex.
[Sun Apr 20 15:38:00 2008] [notice] Child 5240: Starting 64 worker threads.
[Sun Apr 20 15:38:00 2008] [notice] Child 5240: Starting thread to listen on port 80.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-20 21:32 UTC] derick@php.net
Sorry, but your problem does not imply a bug in PHP itself.  For a
list of more appropriate places to ask for help using PHP, please
visit http://www.php.net/support.php as this bug system is not the
appropriate forum for asking support questions.  Due to the volume
of reports we can not explain in detail here why your report is not
a bug.  The support channels will be able to provide an explanation
for you.

Thank you for your interest in PHP.

.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Aug 19 12:05:43 2022 UTC