php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44661 CDATA is repeated if xml begins with CDATA
Submitted: 2008-04-07 14:16 UTC Modified: 2008-04-28 08:58 UTC
From: elaine dot seery at gmail dot com Assigned:
Status: Not a bug Package: SOAP related
PHP Version: 5.2.5 OS: Debian/WindowsXP
Private report: No CVE-ID: None
 [2008-04-07 14:16 UTC] elaine dot seery at gmail dot com
Description:
------------
if data returned by a SOAP request begins with <![CDATA, another CDATA section is added by the SOAP server.

It looks like when a '<' is detected in the return string by the soap server, there is an automatic <![CDATA[ prefix added - even if the < is already the start of a CDATA statement.

Reproduce code:
---------------
data to be returned 
$maildetails = "<![CDATA[<?xml version="1.0" encoding="......";


Expected result:
----------------
<ns1:EmailDetails><![CDATA[<?xml version="1.0" encoding="

Actual result:
--------------
<ns1:EmailDetails><![CDATA[<![CDATA[<?xml version="1.0" encoding="

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-28 08:58 UTC] elaine dot seery at gmail dot com
in fact, this 'bug' comes from using SOAP UI to generate the request and read the response. it's not a php bug at all.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Wed Oct 20 12:03:34 2021 UTC