php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #44645 php5ts.dll Crash (x86_64 base machines)
Submitted: 2008-04-05 09:11 UTC Modified: 2008-11-28 20:49 UTC
Votes:25
Avg. Score:4.8 ± 0.8
Reproduced:21 of 23 (91.3%)
Same Version:8 (38.1%)
Same OS:11 (52.4%)
From: gary dot wilson at coull dot biz Assigned:
Status: Not a bug Package: Reproducible crash
PHP Version: 5.2.5 OS: Windows Server 2003
Private report: No CVE-ID:
 [2008-04-05 09:11 UTC] gary dot wilson at coull dot biz
Description:
------------
Failure case:
Making 8 (or more) concurrent requests to Apache/php requesting XML causes php5ts.dll to throw an application error.

Event Type:	Information
Event Source:	Application Error
Event Category:	(100)
Event ID:	1004
Date:		02/04/2008
Time:		17:47:03
User:		N/A
Computer:	COULL-WEB01
Description:
Reporting queued error: faulting application Apache.exe, version 2.0.55.0, faulting module php5ts.dll, version 5.1.6.6, fault address 0x0000926a.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 41 70 61   ure  Apa
0018: 63 68 65 2e 65 78 65 20   che.exe 
0020: 32 2e 30 2e 35 35 2e 30   2.0.55.0
0028: 20 69 6e 20 70 68 70 35    in php5
0030: 74 73 2e 64 6c 6c 20 35   ts.dll 5
0038: 2e 31 2e 36 2e 36 20 61   .1.6.6 a
0040: 74 20 6f 66 66 73 65 74   t offset
0048: 20 30 30 30 30 39 32 36    0000926
0050: 61                        a       

#####

Event Type:	Information
Event Source:	Application Error
Event Category:	(100)
Event ID:	1004
Date:		05/04/2008
Time:		09:21:48
User:		N/A
Computer:	MEDIAPROC02
Description:
Reporting queued error: faulting application httpd.exe, version 2.2.8.0, faulting module php5ts.dll, version 5.2.5.5, fault address 0x0000acb9.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 68 74 74   ure  htt
0018: 70 64 2e 65 78 65 20 32   pd.exe 2
0020: 2e 32 2e 38 2e 30 20 69   .2.8.0 i
0028: 6e 20 70 68 70 35 74 73   n php5ts
0030: 2e 64 6c 6c 20 35 2e 32   .dll 5.2
0038: 2e 35 2e 35 20 61 74 20   .5.5 at 
0040: 6f 66 66 73 65 74 20 30   offset 0
0048: 30 30 30 61 63 62 39      000acb9 


Hardware Manufacture: Dell, HP
Machine base: 64 bit
Operating System: Windows Server 2003 SP2 (32 bit)
Apache versions: 2.0.55, 2.0.59, 2.2.4, 2.2.8
php Versions: 5.1.6, 5.2.5, 5.3.dev

Description:
This problem was reproducible every time with a combination all the above components.  This was reproduced on 3 separate servers, 2 Dell and 1 HP.

The failure case CANNOT be reproduced on a machine with the same OS, Apache/php versions/config and code base that is running on a 32 bit base machine this was verified on 5 servers.

In our failure case we are generating XML output on every request.  It would seem like this is a issue when running 32 bit Win OS on 64 bit base machine.  Unfortunately, I am unable to test this on 64 bit Windows 2003, however, I did retrograde a 64 bit OS a few months ago due to a very similar problem (not certain if it was exactly the same).




Reproduce code:
---------------
Not a developer.  I will try and get our development team to create some code to reproduce, but they are very busy, so it may take some time.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2008-04-22 07:39 UTC] whydream at 163 dot com

 [2008-05-04 21:28 UTC] miland at vol dot cz
Hello,

I have exactly same problem.

The Apache crashes on x64 Vista Ultimate when the application tries to connect to the mysql database.

Faulting application httpd.exe, version 2.2.8.0, time stamp 0x47a48331, faulting module php5ts.dll, version 5.2.5.5, time stamp 0x473896cb, exception code 0xc0000005, fault offset 0x000000000000f7c2, process id 0xe1c, application start time 0x01c8ae2c9449782b.

Apache 2.2.8 x64 - the same problem with x32 version on x64 host system.
PHP 5.2.5 x64
Mysql 5.1.24 x64

Other scripts are running well, but when I need to connect to the database, the apache crashes.
 [2008-05-17 23:21 UTC] ramons at gmx dot net
I get the same error on XP 64 bit, which is the same as Server 2003 64 bit in regards to 99% of the OS.
Also, same issue, but get it after opening just one connection to MySQL on a different system.
Using latest stable PHP version, which at this point is 5.2.6. Used older version 5.2.3 and get the same error.
Since this crash always happens every time I connect to MySQL it makes PHP unusable at the moment on x64 Windows systems.
 [2008-05-26 12:01 UTC] capsx at team dot lv
edit:

backtrace - Windows XP, Apache/2.2.8 (Win32), PHP/5.2.7-dev, mysql  Ver
14.14 Distrib 5.1.24-rc, for Win32 (ia32)
when calling: 
$this-> sql_db    = mysql_select_db($this->database) ;

http://manaspiezimes.lv/upload/66b75756905ec2ca33bf2cb92d2c6057.png
 [2008-06-03 16:11 UTC] neil dot smith at coull dot com

 [2008-06-04 12:06 UTC] neil dot smith at coull dot com
Correction to last statement : 

"Adding memcache caching of DB response resulted in non-repro"

DB requests were not fully removed in the test harness code. With DB requests prevented, this bug is still repro under high request loads (so it not specifically MySQL / DB connection dependent).

Fault address remains at 0x0000926a in php5ts.dll
 [2008-07-05 12:23 UTC] donald dot lam at live dot com

 [2008-07-05 12:38 UTC] pajoye@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

We also need the script. Is apache a x64 or x86 build (aka runs under 32bit or 64bit OS mode)?

If not already done, please use the pdb files (debug pack) so we can see where it crashes (not only which functions).
 [2008-07-13 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2008-07-18 21:30 UTC] madhav_2k at yahoo dot com
i am getting the same error as well. 

"Httpd.exe - Application error

The instruction at xxxxxxx referenced memory at xxxxxxx. The memory could not be read"

This has completely halted my development and has pretty much rendered PHP on my laptop unusable. 

I use a Dell Latitude with a Intel Centrino Duo Core processor running Win2k Sp2. 

Software versions are MySQL 5.1 , Apache webserver 2.2 and Php 5.2.3 

This has become a major showstopper and a quick resolution is highly desirable!!
 [2008-07-28 12:08 UTC] neil dot smith at coull dot com
[5 Jul 12:38pm UTC] pajoye@php.net

"Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes"

[3 Jun 4:11pm UTC] neil dot smith at coull dot com

Debug backtrace was already provided on 3rd June as required - was that not the information you were requesting ? 

Please consider reactivating this bug and reviewing the backtrace provided. We can retry the repro case and provide additional information if needed, but that appears to be what was requested.
 [2008-08-02 18:50 UTC] lotusxxl at gmailc dot om
I fix this bug renaming the libmysql.dll in C:\Program Files\MySQL\MySQL Server 5.1\bin to libmysql.dll_ 

Now php uses libmysql.dll in c:\php directory and phpinfo shows Client Api version 5.0.19 

Before showed 5.1.25rc

It works fine with Apache 2.2.9 x64 and PHP 5.2.5 x64 version in Windows 2003 Server Standard x64
 [2008-08-02 19:53 UTC] pajoye@php.net
"I fix this bug renaming the libmysql.dll in C:\Program Files\MySQL\MySQL
Server 5.1\bin to libmysql.dll_ 

Now php uses libmysql.dll in c:\php directory and phpinfo shows Client
Api version 5.0.19. Before showed 5.1.25rc"

Ah that is definitively a good thing to do, using 5.1 DLLs with PHP binaries is wrong.

About the backtrace, it seems that you are missing the debug pack, I can't see any symbols (  Error WARNING - DebugDiag was not able to locate debug symbols for php5ts.dll, so the information below may be incomplete.).
 [2008-08-02 22:05 UTC] lotusxxl at gmail dot com
Event viewer shows:

Event Type:	Error
Event Source:	Application Error
Event Category:	(100)
Event ID:	1000
Date:		02/08/2008
Time:		20:17:41
User:		N/A
Computer:	SERVERX64
Description:
Faulting application httpd.exe, version 2.2.9.0, faulting module php5ts.dll, version 5.2.5.5, fault address 0x000000000000e8e4.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
Data:
0000: 41 70 70 6c 69 63 61 74   Applicat
0008: 69 6f 6e 20 46 61 69 6c   ion Fail
0010: 75 72 65 20 20 68 74 74   ure  htt
0018: 70 64 2e 65 78 65 20 32   pd.exe 2
0020: 2e 32 2e 39 2e 30 20 69   .2.9.0 i
0028: 6e 20 70 68 70 35 74 73   n php5ts
0030: 2e 64 6c 6c 20 35 2e 32   .dll 5.2
0038: 2e 35 2e 35 20 61 74 20   .5.5 at 
0040: 6f 66 66 73 65 74 20 30   offset 0
0048: 30 30 30 30 30 30 30 30   00000000
0050: 30 30 30 65 38 65 34      000e8e4
 [2008-08-06 15:10 UTC] sylvaint at sylvaint dot ca
This bug is not strictly unique to X64 based machines.  

The Same bug appeared while using an X32 based machine and the same solution worked.

Thanks
 [2008-08-17 08:47 UTC] collins dot ethans at gmail dot com
I installed PHP 5.2.6 yesterday on x86 64bit machine running WinXP SP2 
(32 bit), using php-5.2.6-win32-installer.msi. I could reproduce the 
problem easily. I used a cmd prompt and ran 'php -v'. It immediately 
pops up a problem window saying, "CLI has encountered a problem and 
needs to close.  We are sorry for the inconvenience." The detailed 
report says: ModName: php5ts.dll, ModVer: 5.2.6.6, Offset: 0009c51d.

However, with the crash, it also prints the version on the shell and 
does it 6 times, poping up the error window 6 times !

Is there a solution to this problem ? I wanted to learn PHP (being a 
pythoner) and this is not allowing me to move forward. Any 
help/workaround for timebeing is appreciated.
 [2008-08-17 08:50 UTC] collins dot ethans at gmail dot com
Forgot to add, the Exception code: 0xc0000005, Flags: 0x0 which is the 
same as others' reports.
 [2008-08-17 09:00 UTC] collins dot ethans at gmail dot com
Some more information: I installed PHP with netools and mcve and 
others. When 'php -v' fails and it prints the version number, it also 
says the following:
PHP 5.2.6 (cli) (built: May  2 2008 18:02:07) 
Copyright (c) 1997-2008 The PHP Group
Zend Engine v2.2.0, Copyright (c) 1998-2008 Zend Technologies
PHP Warning:  PHP Startup: Unable to load dynamic library 'F:\Program 
Files\PHP\ext\php_mcve.dll' - The specified module could not be found.
 in Unknown on line 0
PHP Warning:  PHP Startup: Unable to load dynamic library 'F:\Program 
Files\PHP\ext\php_netools.dll' - The specified module could not be 
found.
 in Unknown on line 0


Now, if I comment out php_netools.dll and php_mvce.dll from php.ini, 
it doesn't print the above 2 warnings, but still fails with the same 
crash information.
 [2008-10-25 06:22 UTC] mail at rad1st dot ru
I get this bug too. After updating APACHE to 2.2.6, PHP to 5.2.6,
I have Zend optimizer installed too.

After I change "zend.ze1_compatibility_mode" to "off" in php.ini, crashes stopped and now all work stable.
 [2008-11-10 12:45 UTC] jackkenyon at optusnet dot com dot au
Same problem
Windows 2003 server on x86 VM. 
Loaded with MySQL, Filezilla server, iis, activeperl, smartermail, python.   
Using extensions of BLENC,DBA, DBX, GD2, Gettext, Mcrypt, mhash, mssql, Mysql, operator, pdo.mssql, pdo.mysql, stats, tidy, threads, zip. 
Get bug message in event log after reboot. 
Get either blank page or 404 or 500 error when load .php in IE. 
Loading .html in IE works fine. 
Loading same .php files works fine on similar setup on Windows XP on VM. 
Have uninstalled & reinstalled PHP numerous times. 
Have found & renamed MySQL dll files (dont know what effect that has had on MySql yet - but it did not fix PHP). 
Don't really have any clues at present as to what else to try.
 [2008-11-10 12:51 UTC] pajoye@php.net
Thank you for this bug report. To properly diagnose the problem, we
need a backtrace to see what is happening behind the scenes. To
find out how to generate a backtrace, please read
http://bugs.php.net/bugs-generating-backtrace.php for *NIX and
http://bugs.php.net/bugs-generating-backtrace-win32.php for Win32

Once you have generated a backtrace, please submit it to this bug
report and change the status back to "Open". Thank you for helping
us make PHP better.

Unless you provide a backtrace there is little chance for us to even try to solve the crash.

I would also recommend to do not use any non core extension while testing (blenc or any other zend optimizer or debugger).

See my previous comment to know how to generate a backtrace.
 [2008-11-14 19:38 UTC] dhulme at gmail dot com
I have seen several reports like this, all of which are unresolved, dating back as far as 2005.  Someone asks for a backtrace, someone posts one, and then nothing happens.  It's like you think the backtrace will help you solve the bug, but when it doesn't, you suddenly become silent.

I am running into the same problem as this forum.  I cannot post a backtrace because this is a production server and I am trying to limit changes on this server.  However, my info is as follows:

Windows Server 2003 R2 SP2
Apache 2.2.10
PHP 5.2.6

-----------------------------------------------------------------
Faulting application httpd.exe, version 2.2.10.0, faulting module php5ts.dll, version 5.2.6.6, fault address 0x000ad094.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
-----------------------------------------------------------------

I was error free for a couple months after remove "php_gd2.dll" from the extensions I was using (I removed all I thought I wasn't using).  Then I found out I had been using it in one obscure script, so I added it back.  The same day I got another one of these crashes.  So I suspect it has to do with that.

Hopefully this information helps someone more than asking for a backtrace and then never giving any more help.

Currently I upgraded to the RC4 build of 5.2.7 to see if that helps.  I will check back in a few days if it solves the problem.

Good Luck!

Dan
 [2008-11-14 22:38 UTC] dhulme at gmail dot com
Update:

5.2.7RC4 did not help, in fact it crashed even more quickly.  However, I don't know for sure what caused it as it was reporting "out of memory" errors before it crashed.  5.2.6 did not have this problem, so I don't know if 5.2.7 really has the same problem or a new one.

-Dan
 [2008-11-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2008-11-26 11:00 UTC] ali at bleurider dot com
I had the same problem too, I am using PHP5.2.6 on Windows XP SP2, MySql 5.1.22 and Apache 2.2.10. 
I am a J2EE Developer originally, but wanted to toy around with PHP, it was too frustrating but finally I changed the said libmySQL.dll to libmySQL.dll_ in MySQL, which is a ridiculous remedy but works.
PHP folks, you just can't get away by saying there is no trace report, you want to be on top, gotta pay the price and move you butt and fix such bugs.
FYI, I had to help my cuz customizing his xcart installation.
such a waste of time and money anyway.
 [2008-11-28 20:28 UTC] hiperjp at gmail dot com
I had the same problem too, I am using PHP 5.2.6 on Windows XP SP3 and las mysql 5.1.22 and Apache 2.2.10 (similar to friend above), with MySQL 5.0.x I am not have this problem.
 [2008-11-28 20:49 UTC] pajoye@php.net
"I had the same problem too, I am using PHP 5.2.6 on Windows XP SP3 and
las mysql 5.1.22 and Apache 2.2.10 (similar to friend above), with MySQL 5.0.x I am not have this problem."

Do not (never!) try other libraries than the ones we provide in the releases. PHP 5.2.x uses mysql 5.0.x which is bundled. Please use it and do not replace it with any other libraries, even from mysql.com (I would say, especially not from mysql.com as they use a different crt runtime).

bogus.
 [2013-09-27 04:49 UTC] ssdaterao at bajajauto dot co dot in
Application popup: httpd.exe - Application Error : The instruction at "0x006aae3e" referenced memory at "0xfef9ceac". The memory could not be "read".

Event Type:	Information
Event Source:	Application Popup
Event Category:	None
Event ID:	26
Date:		9/27/2013
Time:		9:46:43 AM
User:		N/A
Computer:	AFWCASAPP
Description:
Application popup: httpd.exe - Application Error : The instruction at "0x006aae3e" referenced memory at "0xfef9ceac". The memory could not be "read".

Click on OK to terminate the program

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Tue Aug 29 15:01:52 2017 UTC